X Mirror weight paint not working...

heads up! I am pretty new to this.

I just rigged the bones to my model, inserted the armature modifier, and now i am trying to weight paint it. The armature is completely symmetrical (thanks to the X mirror) and the bones have .l or .r.

But now when I try to weight paint, It doesn’t paint on both bones. And I do have X mirror activated on the weight painting options.

Please help. idk why it’s doing this.

FYI: i have blender 2.56

Can’t reproduce your problem. Is the model completely symmetrical? Is the armature?

I just tested with this simple character, no issues. Sometimes the best way to figure out what is wrong is to try with a simple example.

Without access to your blend, there is no way to help more that I can see.


Mirror-Man.blend (492 KB)

i see! i tried it with a simple cube, and it worked perfectly.

I guess that my model isn’t symmetrical. How can i fix it? I used the mirror modifier when designing it.

i got it!

my subdivision surface modifier was messing it up. So i deleted all the modifiers and put them back on.

:smiley: thanks!