X-server shuts-down unexpectedly due to Render Window


I’ve got compiz-fusion and openSUSE 11.0 with proproprietary NVidia drivers running fine on my system. I’m using Blender 2.45 to render-out some still 3d scenes at the moment. If for some reason i’d closed down the Blender Render window and then attempt to open it from within Blender by doing a “Render to Window” or “Anim” command the whole X-server graphics system shuts down and i have to log-in again from openSUSE 11.0 login prompt.

This seems to happen even if i close Blender 2.45 and re-start it again if i had the Render window open while i was running it.

The only way to avoid it seems to be to reboot my computer each time i start Blender. That way i am sure my re-opening the Blender Render Window won’t crash my X-server and hence my system.

This seems rather odd considering everything else is running smoothly. Rock stable in fact, i haven’t had any problems with NVidia drivers or compiz up to this point. It’s been marvellous.

Constructive advice welcome,

Yeah, I have the same issue with Ubuntu, Blender, Compiz and Nvidia… for ages.

I’ve sought the cause for a long time. No luck. Whenever I’ve got impatient and declared conspiracy over nvidia blaming linux blaming compiz blaming blender etc etc I always run into some self righteous “works for me” know-it-all who starts giving me the “free software can’t complain” tune. Some are quick to aim their distrowar fodder at me when it brings me down… none of which does anything at all to help the problem.

From what I can tell, it seems to be a hardware issue which only happens when Blender makes certain calls to certain cards… provided they are on certain motherboards. I bought another laptop with an Nvidia card and exactly the same Linux, same “envy-ng” used to install the graphic drivers; this was no longer an issue. Because of its “doesn’t hit the majority” trend, I don’t think we’re likely to see any progress to resolving this in a hurry. It’s simply not something the devs are likely to see first hand.

I sound negative, but hey… I’ve given up trying to convince people this is not an end [stupid] user problem.

Current fix that works for me: Tell Grub startup that you want to launch into “failsafe” mode (anything that does not use Compiz). You miss your desktop eyecandy, but Blender works just fine.

have you tried to update to blender 2.48? or, better yet, have you tried Blender on a KDE desktop or gnome desktop ?(would that make any difference? )

Not in my experience AMDBCG… only failsafe or I would have recommended the KDE / Gnome alternative. For me the bug was triggered by a distro upgrade when Ubuntu changed from 7.10 to 8.04. Blender never been the same on that box since. I think the main difference is that Ubuntu changed from Beryl to Compiz at that time.

Hi Lancer,

Sorry, i didn’t see that reply. Still getting the problem, glad to see it’s not just [stupid] me though. I have found Blender 2.44 to be more reliable on the older non-compiz openSUSE, but it’s just too boring :frowning:

It’s interesting what you say about the upgrade from Beryl to Compiz making that happen. It’s a shame nobody has listened to you as you sound like you’ve been trying hard to make a perfectly valid point and for me at least have managed to pin it down quite well. I understand why you sound negative, it’s perfectly normal.

On my openSUSE 11.0 system Blender crashes the graphics system when i presss the magic key F12 to bring up the render window. If i do ANIM first from the World menu the render window is cool, and i can hit F12 as many times as i like to do a render and it works fine. It all seems to hang on the method used to open the problematic render window which if opened in a certain way doesn’t give problems. I’m hoping that the newer openSUSE 11.1 which is coming out or perhaps a future release after that will fix that issue, if not i’ll just have to be extra careful whenever i do a render.

But having said that i feel the overall stability of Compiz-Fusion on openSUSE 11.0 is remarkably strong and have not experienced any other problems with it, so it must be something to do with the way Blender interacts with the hardware or like you say what calls it’s making.

Many thanks, all the best and hope my experiences help a little. If not sorry.