xbox controller input script problem

So I’m trying to move the Cube on X and Y axis using my joystick or the pads or whatever it’s called…

Sadly it doesn’t work

I followed this tutorial like a 100 times, it works for it’s viewers, but not for me really…

Now I tried everything, appearently my xbox controller is perfectly OK, joy.cpl (see the screenshot) shows me that the pads are fine, even when I connect the joystick sensor to… let’s say simple motion actuator, it works, but the script just doesn’t want to work…
It doesn’t work with older versions (tried 2.66a and 2.62) and when I tried .blends with any kind of different script that was supposed to do the same thing, it didn’t work either.

-Am I missing some drivers?
-Am I missing some python libraries?
-Did I get the naming of the objects wrong? (it’s all copy-pasted from the tutorial)
-Does the sensor have wrong settings? (index etc.)
-Do I need to change some input Blender settings?

I just don’t know, I’m planning to use it as a motion recorder, so when you play a game, it records the motion, and you can then make a video with a preview of the pad’s motion… Please, any advice?