XVidCap install help wanted

Hello Linux users.
I am on Fedora core 1 and I have been trying to install xvidcap - to no avail.

I got the ffmpeg thingy at:
http://prdownloads.sourceforge.net/ffmpeg/ffmpeg-0.4.9-pre1.tar.gz?download
It compiled ok - no errors.

Then I got “xvidcap-1.1.3-fc1.i386.rpm” and this is the output:

[[email protected] video]# rpm -ivh xvidcap-1.1.3-fc1.i386.rpm
error: Failed dependencies:
        ffmpeg >= 0.4.8 is needed by xvidcap-1.1.3-fc1
        libavcodec.so is needed by xvidcap-1.1.3-fc1
        libavformat.so is needed by xvidcap-1.1.3-fc1

ffmpeg is installed… and the version is 0.4.9. huh?
When I look for ‘libavcodec.so’ and ‘libavformat.so’ I cannot find them. Dunno why they did not get made when I built ffmpeg from source.

Then I tried to get ffmpeg0.4.8 as an rpm and it said:

[[email protected] 03.Downloads]# rpm -ivh ffmpeg-0.4.8-2.fr.i386.rpm
warning: ffmpeg-0.4.8-2.fr.i386.rpm: V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
        faac is needed by ffmpeg-0.4.8-2.fr
        faad2 is needed by ffmpeg-0.4.8-2.fr
        imlib2 is needed by ffmpeg-0.4.8-2.fr
        lame is needed by ffmpeg-0.4.8-2.fr
        libfaad.so.0 is needed by ffmpeg-0.4.8-2.fr
        libmp3lame.so.0 is needed by ffmpeg-0.4.8-2.fr

So - you can see that this is a messy deal and I am confused. I’m not in the mood to track down each of those deps and whatever deps they may need - it’s a nightmare.

:frowning:

I don’t know how much linux experience you have so don’t take offence if I ask questions you may consider obvious.

  1. After compiling did you install the libraries – usually the process is: configure -help, configure, make, make install.

  2. check that the libraries are in /usr/lib or /usr/local/lib

  3. did you run ldconfig and is the path to your lib in /etc/ld.so.conf – this registers the library so that programs can find it. I suspect this is why xvicap didn’t find your 4.9

After the above your 4.9 should be properly installed.

As for:

I’m not in the mood to track down each of those deps and whatever deps they may need - it’s a nightmare.

I don’t know what to say? – Do you expect someone to do the work for you?

I run Debian, all I had to do was “apt-get install xvidcap” and it downloaded and installed the program and all its dependencies automatically.

GreyBeard

Greybeard, thanks for your tuts BTW.

I say I am not in the mood to d/l all that stuff because I am on dial-up and also, I am just a little frazzled by that list of deps.

I wonder why my install from source of ffmpeg did not compain about the list of things that the rpm does.

About ffmpeg:
I did do a proper .configure, make, make install
I did not do an ldconfig, but after a restart(does this help?) and doing one on another app, I find that the xvidcap rpm still complains about it not being found.

I have updated my locate database and cannot find those two libav*.so files. I don’t get why.

Are these the libraries you refer to that I should have in /etc/ld.so.conf ?

Ok - I am going to see if I can find a repository for YUM or RedCarpet.

You know, I usually have no trouble installing software - xvidcap and the Python IDE Eric3 are two that I just cannot nail down. I hope to strike xvidcap from the list !

Thanks for the reply.

I would just use the 4.8 rpm given the missing libs and try to meet the dependencies (I’m curious about the libs though). The source install probably didn’t complain because it can probably compile without support for mp3 and aac.

For future reference:
/etc/ld.so.conf contains a list of directories other than /usr/lib that might contain libraries. When you run ldconfig it scans those directories and makes any new libs available for linking. It is in my startup scripts but I don’t know about Fedora. I seldom reboot however so I usually just run ldconfig after compiling a lib from source.

[email protected]:~$ uptime
04:55:37 up 53 days, 23:40, 1 user, load average: 0.14, 0.25, 0.2

Good luck,
GreyBeard

You have given me a hint by mentioning “mp3 and aac”.
I have found some options to configure…
I don’t know what aac is, but I suspect I am going to find out. %|

I usually leave my machine on for literally months (UPS saveth bacon), but there was a bad electrical storm and I took it all offline just in case. Damn, the weather can really screw a good uptime count!

Hoo Boy - when I tried to build xvidcap from source (it includes ffmpeg) I get syntax errors in the c source code…

It just ain’t my day!

Ok - I have managed to install XvidCap.
I dunno if it works with sound recording and all that jazz - still to figure-out how it works, but in case anyone wants to know:

I used DAG’s Apt/Yum repository
a. Add this line to your /etc/yum.conf (as root):

[dag]
name=Dag RPM Repository for Fedora Core
baseurl=http://apt.sw.be/fedora/$releasever/en/$basearch/dag
  1. Then type:
yum update

Wait for 1600+ package headers to download (+1 hour on my dial-up…)
3. Now:

yum install ffmpeg
  1. Then go and find xvidcap-1.1.3-fc1.i386.rpm (sorry can’t recall where I found it, maybe on the sourceforge page)
rpm -ivh xvidcap-1.1.3-fc1.i386.rpm
  1. It should install with no problems.

HTH

Greybeard: Could you let me know the URL of the APT repository where you got xvidtune from?

Greybeard, could you let me know what settings you feed to xvidcap?

I have done some tests and it seems that MPEG4 and MSDIV4 seem to have the smallest filesizes. What do you use?

What settings do you have for your audio?

Also, what number of max frames do you set it to record?

Questions! Questions! Questions!
:wink:
(I am using gvidcap, because xvidcap just seg faults all the time. As it is, things are touchy!)

Here are my settings:

5 frames per sec
filename: whatever.avi
max frames 0
max time 0 (zero means no limit)
Codec: MS_DIV2 (everybody can play this it seems)
image quality 50
compression 0
shared memory and mouse pointer selected (white cursor)

enable audio selected
/dev/dsp
22050 sample rate
32000 bit rate
1 audio channel.

I found that I had to twiddle with my soundblaster live a lot to get it to record. If you use KDE follow the help file instructions for KRecord and try to get sound recording working first with that or perhaps try with the gnome equivalents.

If you use a soundblaster live and can’t get it to work ask again after trying and I will try to help you sort it out.

edit
Forgot one of your questions:

If I remember there was a deb on the xvidcap homepage (dpkg -i thename.deb). The repository I use for mplayer, ffmpeg, avidemux etc is:
ftp://ftp.nerim.net/debian-marillat/ unstable main

so the entry in my sources.list is:
deb ftp://ftp.nerim.net/debian-marillat/ unstable main
**end edit **

Hope this helps,
GreyBeard

Tah.
That (I hope) concludes the xvidcap mystery, thanks for all the help.