Yaf(a)ray is not working properly

Hi all!
It seems Yaf(a)ray is not working in my Blender application properly. My operating system is Windows Vista Business service pack 1. Is it support to Yaf(a)ray?
Everytime I tried to render with Yaf(a)ray a black window came as a result. And the massage also appeared in the Blender black text window as I mentioned below.

No export directory set in user defaults!
Will try TEMP instead: C:\Users\MyName\AppData\Local\Temp
Couldn’t FIND registry key for yafray,is it installed?

Please, I want to know the way of fixing this problem. Anyway I never knew about a registry key for Yaf(a)ray. Where I can find it.
I appreciate if someone give me a sufficient solution for my case.

First, are you sure you’re trying to use yafaray? It looks liked you tried to use yafray. Second, you have to install yafray to get it to work (but I recommend installing yafaray).

Quoting the installer:

“If you intend to use Yaf(a)Ray together with Blender, just startup Blender and choose the “YafRay Export” script from the menu “Render”. Set up your materials etc. and use the button labeled “RENDER” on the YafRay GUI to start the rendering process.”

I have yet to get the materials to work properly.