Yafaray Installation Help

I’m trying to install Yaf(a)ray 0.1.0 on my Ubuntu Linux platform.
I’ve downloaded Blender 2.48 from GetDeb website and installed it.
I downloaded Yaf(a)ray from Yafray website ( the package built for Ubuntu Hardy )
And everything look fine at first once i install Yaf(a)ray 0.1.0

Then, I ran Blender and find for Yafray Export 0.0.3 button. But, there’s no:


what i must do ?


You possibly have two .blender/scripts folders now and your Blender install is using the wrong one. Either delete the wrong one or copy the yafaray export scripts from one to the other.

i think, that’s not organic.
after i delete all the files related to Yafray in .blend/script and reinstall the yafray, it still the same.

i got this :

i think, it’s maybe because QTLib. i installed : libqt4-dev and libqt3-headers.
any suggestion ?

Not really, I didn’t install, I built from source.

All I can suggest is that you remove Blender and Yafaray, rename any .blender folder and .B.blend file you have, then reinstall.

Look for the Yafaray render option in Scripts => Render, it will not show on the render tab, use the Yafray option there, but use the Yafaray render button on the Yafaray gui.

Do you have a version of Blender downloaded from www.blender.org? If so, inside that folder there is a .blender/scripts folder. When you installed the blender .deb it also installed a .blender/scripts folder in your /Home directory.

Open Blender, and in User Preferences change the default directory to search for python scripts to read /Home/username/.blender/scripts (Where username is your username).

owh … that’s true Organic.
Yafray have put the exporter at wrong place.
They put the expoter at : .blender/scripts/blender

I’ve fixed the problem and it’s working.
thank you very much Organic :slight_smile: