Yafaray Noise Problems

Hi Yafarayers,

i am still having big problems reducing the noise in my Renderings. I’ll post some results with their corresponding settings. If someone has got an idea for improvement, please let me know.

Thank you, Powie

Attachments



here the PT Render. Notice the noise on the cubes.

Attachments



I really H.A.T.E. that noise… =(

Attachments



Pathtracing with glossy materials can be a little noisy.

Try reducing AA and FG Samples and instead increase IBL Samples. Also it may help if you use Sphere rather than Point lights, also possibly with increased samples.

The best thing would be to post the .blend.

EDIT - Reducing the AA Threshold will help too, but have you read the documentation at Yafaray.org?
http://www.yafaray.org/documentation/userguide

Thanks Organic for the fast reply. Yes, i am reading the user guide und try to comprehend everything i read in a reasonable model.

I am not sure what is indoor and what is outdoor. if i have three cubes and a plane and a environment texture i assume that it is a outdoor scene.

Did you say -> reduce <- (to lower…) the AA settings? At the moment i am having a test render with high sample values everywhere. And i am using a ‘area’ light (blender-area-light) and a meshlight (high samples, high power) and a environment map with high sample rate.

I will post the blend when it’s finished. That’s very kind that you offer to have a look and the .blend.

Here my last two testrenders with meshlight. It’s not easy to figure out the inter-relationship of all the values =)

Powie

Attachments



here is the .blend, but without the .hdr (packed size is 5.4 MB…).

Greets from Frankfurt,
Powie

Attachments

YafTest_4Ccubes.blend (216 KB)

turn the sample of the lights up, commen mistake.

Unfortunately caustic noise is something I don’t properly understand yet. You would get much better advice at yafaray.org, but here is a starting point.

YafTest_5Ccubes.blend (250 KB)

It is also possible some of the noise is from the .hdr and another .hdr might give different results.
I moved the meshlight to another layer, just to be sure it wasn’t the source of the noise.

Hope this helps some, and doesn’t misinform too much…

Thanks for the help!

I did some tests with higher sample values (like 256…) and the noise dissapeared.

That’s a ‘direct light’ render, a method that i neglected after luxrender uses it for low quality preview renders. But in Yafaray it’s a normal method.

I read a lot of good stuff from organic on this forum, and thanks ionee

Pow, Frankfurt/Main

Attachments


I’m running into trouble using yafaray as well. Would you mind posting the yafaray-settings you used for this render, as well as the light-setup? It would really help me getting some sort of feel for the lighting with yafaray. I’d really appreciate it!

my yafaray tutorial:
http://vimeo.com/4095562

should help you.

Thanks a lot ionee. Unfortunately, like most videosources, this tut is blocked by our companys security policy, so I’ll not be able to make use of it. Are you aware of any good text-based tutorials about yafaray?

There is some useful documentation at yafaray.org:-
http://www.yafaray.org/community/forum/viewforum.php?f=14
http://www.yafaray.org/documentation/userguide

(The images above use HDRI lighting.)

Thanx. I found this tutorial http://www.yafaray.org/documentation/tutorials/studiolighting especially helpful, as it covers a lot of aspects. It’s not too detailed though, but it will help getting started.