yafaray on osx renders to black

hello
ive been trying to get yafaray working on my imac. so far this is what i have

imac intel core 2 duo
os x 10.5.8
python 2.5
yafaray 0.1.1 - fresh install, ive never had it on this machine before

ive installed it as per the user instructions and set the pythonscript path to the right spot and can select yafaray render from within blender.
ive gotten some test scenes from the yafaray site to test
ive tried the basic default scene with the lamp set at intensity’s varying from 1 to10 and the lamp as a lamp, sun and spot

every time with every scene i get the render window to display almost instantly - slow is .10 second - and its completely black.

ive hunted around on here and yafaray’s site for something like this, and can only find people with older versions of the renderer or are using linux.

now i don’t know what to try, does anyone have a direction to head to now?

ive found someone had similar issues, and the only cure they could get hold of was to step back to yafray 0.9… so thats what ive done for the time being. but if anyone has a proper fix to get yafaray 0.1.1 working, i’d love to hear it.

Can you post a blend file that doesn’t work for you?

Blender 2.49a
Yafaray 0.1.1
OSX 10.5.8

Using the test scenes from yafaray.org



Renders fine for me.

Richard

thanks for the reply
those two files you’ve shown are the same ones i downloaded and tried. with yafaray 0.1.1 i got total black. i tried the light bulb one with yafray and got a very ugly result. ive just tried to render the light bulb one to post here and blender crashed without any warning. but i can use the default start up scene of the cube, lamp and camera and with yafaray 0.1.1 i get black every time. (while i had 0.1.1 installed that is)

It sounds to me like your exporter isn’t running properly. It can do things like this if a new version is installed over an old one. I’m afraid you may need to uninstall Yafaray, including all of the export scripts, and reinstall it from a clean slate.

Sorry for the curt, and somewhat unhelpful reply. Hopefully your problem is as simple as two versions of the export scripts interacting badly. Good luck!

Astroman Pete - :smiley: that wasn’t curt or unhelpful. sounds like someone short on time but knows a possible answer… thanks for that.

I have reinstalled yafaray twice (so for a total for 3 times) but Im not sure if i was able to clear it completely from my system each time - though it definitely was a fresh install the first yesterday. Im new to the OS X system so can’t be absolutely certain i had it clear each time. but i’ll try again.

one thing i have noticed which makes me think ive not cleared it correctly is that in blender the render tag for a exported render is to “Export Yafaray 0.1.1”. so im not sure how to definitively ascertain which version Im running now. only that yaf(a)ray refused to work until i got yafray installed… I hope thats meaningful to someone

I think ive cleared all the parts of yafaray - it’s no longer present in the render drop down as export yafaray 0.1.1 so thats a good sign. I do have yafray as a render function in the choose renderer option.
previously any yaf* renders where crashing blender this morning.

Did you follow the installation guide:-
http://www.yafaray.org/documentation/install#osx011

You say you have the Render panel dropdown for Yafray - are you using Blender 2.49 ? You also said there was no problem until you installed Yafray. Did you try uninstalling Yafray ?
Yafray development stopped in 2006 and will not be continued, so it is not really a long term render option anymore.

organic - thanks for having a look here.

yep, I followed that install guide - i used both as a trial to see if id done it wrong the first time. but I’ve got the .py link file in the pythonscripts folder that it makes on install.

yes, i have the 2.49 version of blender - sorry for omitting that

i think i need to clarify this - i had no issue with the installation of yaf(a)ray, but it would only render black, so it installed but doesn’t appear to work

ive tried to uninstall it - but its a very messy way i feel - ive been searching though folders looking for yaf* related things and deleting them, is there a neat/proper way to uninstall the yaf* stuff back to a clean slate?

I knew yafray 0.9 is no longer developed, Im hoping this is a temporary situation until yaf(a)ray works properly.

sigh, now i seem to have only yaf(a)ray installed, at least as far as the python scripts say, but blender shows ONLY yafray in the blender render dropdown, and the menu tab render window (on the title bar) shows only Export YafAray 0.1.1
using just the default scene to try and render something, i select from the drop down, yafray, and it renders half the image in patches, and then crashes half way through and then provides the handy dialogue to send to apple.
now, does anyone wanna hazard a guess how i get rid of everything to do with either yaf, so i can get a clean install?

As I understand it the Yafray option has been removed from 2.49, so it simply shouldn’t be there…?

When uninstalling there are also some _yaf* files.

organic, i like to be unconventional, getting a bug that shouldn’t be possible is more interesting dont you think,

never the less, ive attempted to clear everything out as even blenders internal renderer was crashing the default scene (wtf!?) ive got a brand new install of blender 2.49.2 to be exact and a fresh install of yaf(a)ray 0.1.1 installed to the pythonscripts option with the file path in blender set to find it.

i dont have any choices for rendering in the drop down menu in the render tab - theres no drop down at all, but I do have Export Yafaray 0.1.1 as a menu item in the render list. which brings up the script window, where i can render at least the default scene… so far so good. BUT seeing as its not a drop down-able choice in the render tabs, all the extra settings such as lights, materials and GI are at the moment hidden from my novice eyes.

so, it looks like the script menu item Photon Mapping is a new term for Global illumination? it seems to have similar options at least? does this make sense to the yaf experts reading this? have i lost it yet?

success!
test file rendered correctly, as far as i can see.

thank you very much everyone in this thread.

looks like yafray and yafaray have completely different setups. so now my project with its yafray lighting setup will get a complete rebuild… theres a hell of a lot extra features that i can see in yaf(a)ray… you guys have been extremely busy…

Attachments


They are completely different render engines. Yafaray was written from scratch.

You can find render and material set up here, or Scripts Window -> Scripts - > Render -> Yafaray


Glad you got it working…

do you have to keep using yafray 0.9 with os x 10.4.11?

From yafaray,org

Important: YafaRay is compiled against Python 2.5.1-Apple, the pre-installed one! Don’t install any other Python-version. This could break functionality.
The tested configuration is using the preinstalled Python 2.5.1-Apple on OSX 10.5.x (resides in System/Library/Frameworks) and the Blender compiled with Python 2.5 “custom”, too!
Other combinations may not work.

You could ask in their forums for a specfic build for 10.4.11 if this doesn’t work.

Richard

its there an issue with 10.4 being a 32bit OS and 10.5 being the 64bit which is something to do with yafaray 0.1 not working yet? if you can’t upgrade, then there might be a problem, but can’t you just get the mac os upgrade to 10.5?
id get a link if i could remember where i read that snippet

Hi, I was having the same problem of rendering to black on my OSX. So I followed your example and freshly re-installed Blender and Yafaray and my scene still rendered black (My scene is the tut. for a kitchen from CG tuts). So I tried the example scene you used and got a clean nice render. So here is my blend file, and I was wondering if anyone would be willing to look at it and tell me what I did wrong. Thank you. :smiley:

Attachments

yafarayattempt8.blend (869 KB)