I just updated blender as i couldn’t get Yafray to work and installed Yafaray. I tried it on a simple box and it worked almost as fast as the internal renderer (albeit much darker). I then tried it on my model and while the internal renderer can do it in around 5 seconds Yafaray took 45 mins to do less than 5% (i gave up after that as it was just a test). Now i know the render process is meant to be slow and arduous but is this not ridiculous? (at that speed it would have taken over 15 hours). I am new and it may usually take that long especially as my computer is only dual core but at this rate a 800frame animation would take 12,000 hours to render. If ti is usually this slow is there a test yafaray setting or something smaller as i’d like to see the lights and textures possibly without rendering the whole thing.


Things to do with my rendering:
Running on iMac 2.8 Ghz core 2 duo extreme
Newest Blender, newest yafaray
Simple object renders in seconds
The way it renders is through Yafaray exporter version 0.0.3 or something similar

You can’t really compare the two, Blender uses a scanline renderer, while Yafaray is a Ray Tracer.
However, the render settings you use will make a difference and Yafaray does support border rendering if you only want to render a section of the scene.

There are some examples and tutorials at yafaray.org and, of course the user guide and documentation which are highly recommended.


Well, those render in seconds. the second taking slightly longer. so it must be something to do with my model. Is there a way way to streamline it for rendering or something, or maybe i’m just doing something wrong. Any ideas. I’m afraid i’m completely new, is there a way to get information on your model or scene?

A more complex scene will take longer to render.

In edit mode, at the top of the page next to the Blender version number you can read how many Vertices, Edges and Faces there are. Having high levels of subsurf on will also slow a render.

What are your render settings?
If the file is not too large you can post it here.

Actually I doubt that it is the geometry, that is the problem here. The number of vertices is not that much a factor for rendertime (it surely is), the rendering method, lighting as well as scene geometry are the important things.
It would be good, if you told use some more about what you’re trying to render. Blender, for example, can’t handle any kind of indirect lighting while Yafaray does. And this is costly, especially for indoor scenes and similar things. So, a scene which renders in seconds in the internal engine can easily take hours in yafaray, nothing unusual. But without more information on the scene we can’t really pinpoint the problem!

On a side note, forget yafray, yafaray is the way to go :wink:

Ok thanks. The number of faces/edges/vertices doesn’t really mean anything to me without comparing it to something so although it seems quite large and for lighting there are just 1 or 2 simple lamps. I’ve added the file i’m using for you to test and see if you want rather than lots of writing of specs. Thank you for any help and hopefully i will be fully set up with yafaray soon enough.


Render.blend (225 KB)

I think there is something odd with your mesh.
You have very high levels of subsurf on it. Turn it down to two and enable Set Smooth, it will render faster. But even then it is very slow.

I followed the same tutorial:-

It renders in 46 secs. at 810 x 810px

I’ll look into it some more, but I don’t know what it is - could the .blend file be corrupted in some way?

I appended the mesh to a new file, turned down the SubSurf, enabled Set Smooth.

I think there was something wrong with the mesh, it rendered really slow until I removed doubles(removed 31 vertices), then turned Subsurf render level down to one and back up to two.

Seems to work now.

Hope this helps…


render.blend (527 KB)

Hm, true, the subsurf levels are unnecessarily high. Do what organic said.

However, I found the real problem. You have vertices in “outer space”. Literally. Positioned somewhere far, far beyond the horizon.
You somehow placed vertices at positions like 10000 Blender Units away from the origin. Your object scale in x direction is also 10000. This is surely an accident, but you can simply delete these bad vertices by selecting all of the vertices of the main body of the teddy (that means, don’t hit “a” to select all, but select them using the Box Selection tool), then hit Select -> Inverse and Delete them.

Renders in less than 2 seconds on a single core of my quadcore machine then :wink:

Thank you so very much. Now all i need to do is learn to animate it. Anyone know how to change the render size, I can’t seem to find it anywhere. As in the size of the picture rendered.

Good catch Myke, that would slow things down a bit

Change the rendersize in the Renderbuttons in Blender’s Interface. Yafaray uses these settings directly from Blender and does not edit them from within the Exporter script.
No problem, by the way :wink: