yafray 0.0.9 crashes with toon or edge?

I´m trying Yafray 0.0.9 for the first time. When I used it with a basic tutorial (three spheres and a floor), it worked fine.

But later I tried it in a scene with a rigged character with toon materials and “edge” turned on in the output panel of the scene settings, and suddenly it crashed blender.

I tried it again on the original test scene that worked fine before (three spheres and a floor) and it crashed again.

I re-installed Blender (2.48a) and Yafray (0.0.9) and it doesn´t render anymore, no matter the complexity of the scene. It also happened in two different computers.

I´m working on windows XP 32 bit. As a newbie, I would prefer not to install Yaf(a)ray, it didn´t worked as easily as 0.0.9… Can you help me?


Try enabling the Xml button on the render panel.
If that doesn’t help you could try an older version of Blender, though you may have to go back a ways. I think 2.43 was the last one to definitely work ok with Yafray - though a later one might.

The problem apparently stems from using different compiler versions for Yafray and Blender, and since Yafray development has stopped, the problem won’t go away.

…and welcome to blenderartists!

Many thanks for your quick answer, it worked as soon as I turned the xml button on :o

I´m really a newbie!!!