I installed the new Yafray for Mac OS, and the package says 0.0.7. The installer says it’s 0.0.6. I thought this might’ve been an oversight, but Yafray doesn’t seemt to work when I try and use it to render images. I’ve had no previous installions of Yafray on this computer. It seems to try and work, because you can see Yafray analyzing the scene with the black background and blue squares, but there’s never any output. Is there some technicality I’m over looking? Also, I am unchecking XML so it doesn’t export the .XML file.

yafray 0.0.7 works fine for me with Blender 2.34 on mac os x. You’re right, I think the installer does say 0.0.6. Try opening your console in applications/utilities to see what’s going wrong. I keep this open when using yafray because it tells you exactly what it’s doing - even has a progress meter.

One of the common problems is not setting an export directory for yafray in the user prefs. Just pick any folder. Note, even if you set this, after a crash, Blender wipes the directories so you have to set them again. I think the same goes for new scenes.

I tried what you suggested and selected a Yafray path in user prefs, but it’s still not working. I even tried exporting an XML and it opened within Safari with two wierd text boxes. My Terminal didn’t give me any info on what was going on with Yafray, it just sat there welcoming me to Darwin. The wierd thing is, not only does it analyze the scene, it completes rendering, the picture is just all black. Is there a lighting thing I’m screwing up?

i had the same problem with the previous version, but it does seem to be solved with the new version. and i also noticed the incorrect version number on the installer.

check in this path ( ./usr/local/lib/yafray/ ) to see if it has actually installed anything. if there is content there, and you have a path set to save the export, then you should be able to render with it, and the problem must be internal, like lighting or something. maybe.

verify that you have an output path in your render setup as well, so it has somewhere to save the rendered image to.

also, check that the export path is saved in your default preferences. ( open an empty document, set the path, then hit ctrl-U, to save user preferences )

hope that it does work, cuz it is a good renderer. good luck!

jim ww

If you want to render an XML, don’t double-click it. You have to open a terminal and type cd /usr/local/lib and hit return. Now do ./yafray and drag in the XML, then hit return.

Also, the console that I mentioned earlier is not the same as the terminal, a lot of people mix that up. There is an app that looks like the terminal in the utilities folder called console. This is the standard output for all apps so you might see a lot of messages there already - just scroll to the bottom. This is your best bet to finding out what’s going wrong.

It is possible that the lighting is wrong because you have to make your lights about 3 times as bright for yafray but I don’t think that would make a black render unless your camera’s off too. If it’s rendering ok in Blender, then your scene’s probably ok.

I think all your setup is fine you just have to sort out lights. Try changing your light to area light first , or try rendering demo scene from Yafray site . If all that doesn’t work check your permissions on /usr/local/bin/ and change them to yourself or at least enable read&write for all.

There’s no Yafray folder in my user/library so I’m off to try and reinstall. I did try changing the lights to area and boosting the brightness, but no luck still. I’ll see what happens…

Just realized my problem. I downloaded the Panther version, I’m still on Jaguar…oops! Sorry everyone! :expressionless: