yafray and blender2.48 compatibility.

i just moved from blender 2.44 to 2.48 and it is the bomb, problem is when i try to render with yafray it immediately crashes, blender.exe has encountered a problem blah. blah. blah. is there a problem with compatibility with yafray and 2.48. i need my yafray if i’m gonna rock blender. anyways if anyone can help me i will be deeply indebted.

Hi, I’m not very used to Yafray, but I have used it for some things, and tested also Yaf(a)ray, recently.

With 2.48a, I would advice you to use Yaf(a)ray 0.1.0 ,which is the most recent version (Yafray is no more developped). Use the Exporter Script named YafRay Export 0.0.3, in the Script–> Render menu.

Dont use the render interface in Blender, but the one in the script window. The Render button is here.

Don’t forget to download and install also the Qt Lib files :

Download from here:


thank you and i will try to download the latest yafray release. i have yafray 0.0.9 i think. if that dont work maybe ill try another renderer, can anyone suggest a good renderer with good GI and hdri capability? what is the problem im experiencing is it a bug or dosent blender support yafray anymore, the option is still there to use yafray in blenders GUI.

Blender doesn’t support yafray anymore. Now Yaf(A)ray supports Blender with an exporter script.
There was the idea to remove yafray from the list of renderer. But was never done.
The yafray selection should be removed now, it leads to confusion.

The current yaf(A)ray export script is working very well. So Yaf(A)ray is a good solution for GI and HDRI lighting.

im getting frustrated, i have installed and reinstalled yaf(a)ray and the qt libs 6 times. could someone tell me, step by step, how to install yaf(a)ray and where to put the plugins and qt libs exactly. when i go to the scripts window and look in the render tab, save render layers is the only option there. should i remove yaf(a)ray and blender and reinstall everything. if anyone can help me it would be appreciated. yafray’s forum is horrible i still havent got a confirmation email.

You are on Windows?

  1. Install the latest blender 2.48a
  2. Ensure that you have more than 3 export formats in your blender export.
    (sometimes the installer has a problem on the 2nd install with different install option)
  3. Install Yaf(a)Ray Win32 r287 and Qt Libs
    (you will be ask about the blender folder)
  4. Check that there are two qt-DLLs in your blender dir and some yaf* scripts in /.blender/scripts
    (the scripts directory depends on your selection on the installation of blender)
  5. Start Yaf(A)ray only with the script
    (Menu->Render-YafRay Export 0.03) or (Scripts->render->YafRay Export 0.03)

in my scripts window in the export tab there is nothing, in the render tab, there is now yafray export 0.0.3. i click on yafray export 0.0.3 i get an error “this application has failed to start because the application configuration is incorrect. reinstalling the application may fix the problem.” now i have two blender folders, one is in program files that contains blender quick start guide .pdf and a python25 zip file. the other is in my documents and it contains the same stuff only more of it, with a .blender file that contains plugins and stuff. i installed yafray into the program files blender file which dosent contain as much stuff. thanks for all the help.

well everything ive tried and all the suggestions have failed, there is only two options left, first, install the python 2.6 build and reinstall both blender and yaf(a)ray, i have python 2.5, i heard you need at least python 2.5.1. if that dont work i will have blender 2.44 and yafray 0.9.0installed and blender 2.48 for when i dont need yafray, sure would be nice to use the new yaf(a)ray though. i will let you know if it works.

I don’t know why it doesn’t work for you.
My english is very crappy - I don’t know why nobody with better english will help you.
Here it’s workin’ and I think I have said all my ideas about blender 2.48 and yaf(A)ray under XP.

ragman, I haven’t checked, but it’s possible you want python 2.5.2 - have you tried it?
Also try posting at yafray.org with any console error messages, they are quite helpful there.

well i tried python builds, 2.5, 2.5.1, 2.5.2, 2.6, none worked, i tried installing blender 2.44 and when i ran yaf(a)ray i got a different error, i imagine that error is a compatability error. is this an issue with xp service packs or patches? i have service pack 2. is this an issue with c++ redistributable packages i just installed 2005 but not 2005sp1 or 2008. i am literally pulling my hair out. am i not installing blender and yafray in the proper locations? all of which are exclusively in program files folder, i declined the option to put blender files in application data.all i know is the problem lies in compatability with the new builds of yafray and blender, i dont think the problem is on my end, the previous versions worked fine,blender 2.44 and yafray 0.9.0.please someone help me. i will check yafray.org forums also. thank you for the help.

sometimes it is the most simple things that give you the most trouble, the problem was i installed the C++ 2005 redistributable package when i needed the C++ 2005sp1 redistributable package. aaaaaahhhhhh!!! maybe my 2 day headache will help someone else with the same problem. thanks everyone for the help. now i will copy this text to yafray.org except for this sentence of course and i will get back to blending.

Glad you got it working.