Yafray camera question

I like to thank the tutorial writer of the Yafray / Yable tutorial
It’s verry clear and looks good.
There is ony one problem. When i open the final xml file in GUI i get a camera error.
I thought maybe there is something wrong with the settings so i tried it on my laptop computer… and yes the same camera error.
What can be the problem, or do i have to rename the camera?

Who can tell me more?

Kind regards,


Hi scotch,

thanks for try`in the tutorial :slight_smile: ,

yable seems to handle the camera on it own, so

could you post your blend file or,maybe, post your xml here,or
at the yafray site,using the"code" feature.

that way it`s easier for us to give you a hand.


i made a small test so you can see what’s wrong.
you can find it here http://www.csnmedia.nl/yaf/yaftst.zip

Hope to here the good news about what’s wrong.

Hi Scotch,

sorry it took so long to get back to you,

i rendered your file without a hitch,and your XML looks right,

so im really sorry i cant help any futher, except to say
that you may want to post this at the yafray Q&A section,
and maybe someone else can help.


if you would like to see the picture your file produced you can
see it here:


Thanks for the test, but i still get the errors on all of my computers (6)
i hope there will be a Blender with implemented Yafray verry soon.

hi scotch,

did you get it going. I have the same problems, i think


it might be an idea not use a gui, eh?

hi blendermax,

No tusing a gui uhm, didn’t think of that, 'cause i don’t know how it’s exactly done.

Using WinXP:

run C:\yafray\yafray.exe

and …

How do i get to my .xml file?

Feeling stupid


cd yafray
yafray.exe <path to your xml file>

here ya go!

thx b-max,

It does more than with the gui, but it renders a black image. I have read about this so i gonna look that up.


have set light to:

<light type="pointlight" name="Lamp.001" power="400.000000" cast_shadows="off">
  <from x="2.083862" y="-6.801172" z="2.937355" /> 
  <color r="1.000000" g="1.000000" b="1.000000" /> 

and yes i can see my bullet. It’s all white but i think that has to do with all the setting options. Gonna try it.

btw when in dos-mode i get the following 3 warnings:

[warning]: Use transmitted insstead of transmited
[warning]: 'samples' parameter obosolete, use 'AA_passes' instead
[warning]: 'tolerance' parameter obosolete, use 'AA_threshold' instead

Does these warnings prevent a ‘good’ rendering? e.a what do these warnings mean?

why dont you just read them? :-?

the first one means that yable misspelled transmitted, samles are deprecated, AA_passes are used instead in the newest release, and the same applies for tolerance. All that information can be read from the above text with a little common sense.