Yafray caustics gone wrong.

I’ve never used Yafray before, so i want to test it.
I’ve created a small test scene, to figure out how to use caustics(screen nb.1)
and i was quite happy:

screen nb.1

So i created another scene with a glass, nearly the same setup as before, but this time iam not so happy with it. The caustics are horrible:no:.(screen nb2.)

The Settings are:
300000 Photons
100 Search
7 Depth
Blur 0.150

1 Lamp
1 Photon lamp.

I don’t like the way the caustics are reflected in front of the glass, i only want them like on the first screen with the ball.

screen nb. 2

try a spot lamp insted

That looks about how it should. If you don’t want caustics like that, you’ll have to move your photon lamp.

Personally, I love the caustics on the second picture :slight_smile:

i also like the caustics on that glass… and have seen such patterns made many a time. since the unwanted caustics are reflected and not refracted, have you tried turning down/off the glass material’s reflectivity? appearance-wise, the glass is mostly refraction anyway.

Thanks for the advices, i brightened the image a bit.
I’ve added a sun light to the scene, and now the hole scene is a little brighter and the caustics are not so ‘strong’.


i gotta say, like most people, the caustics of the glass look awesome!

Here is a small update:

This is one frame of my 500 frames fluid animation.

Fluid Resoluton of 175, it took me 10min for rendering this single frame.

cool, I’m looking forward to seeing to seeing the finished animation. Although, at 10min a frame, thats going to take a while to render. What are your yafray settings?

Raydepth 15
Processors 2 ('cause of DualCore)

Method: Full
Quality: Low (For Testings purposes)
Depth: 5
CDepth: 5

Cache enabled
Photons enabled

And the Photonlamp settings are:

300000 Photons
search 100
Depth 10
Blur 0.150

I think you could make it render faster by lowering some settings:
Yaydepth really doesn’t need to be 15; 7 or 8 should be fine.
You could get away with lowering your GI depth settings.
Lowering the number of photons and photon depth from your photon lamp cuts render times, but you risk losing the quality of the caustics.

and a warning:
When using cache, you may notice that you get flickering when you do animations because the cache only calculates GI for some pixels. To fix it, lower the precision value (so it calculates GI for more pixels) or turn off cache.

The Raydepth needs to be at least 11 i think, because 7 or 8 is to low, so the water is black in some areas.

i disabled the cache, because you were right, there is some kind of flickering in the animation.

Anyway i reduced the rendering time to 6 mins.
This should be better. :smiley:
thank you so far.

I’m glad it helped, good luck rendering!

the stills look great! I can’t wait to see the animation and/or the blend file. Do you plan on posting?

Yupp its coming, but the rendering takes a very long time and i render only a few frames per day, so currently its rendering frame 260 of 500 frames^^. it took me 12 min to render a frame.

I’ve found that sometimes having the cache off gives errant pixels. What I did to fix it was turn caching back on and set ‘prec’ to 1 and ‘ShadQu’ to .99.

I’ve notice error pixels too. sometimes ill render something and ill get a couple black pixels scattered randomly around the render.

If you use the cache for animation, you can usually set prec to at least 2 or 3 without noticing any flickering. You can also improve rendertimes by setting the shadow quality lower (.9 or so), and and turning on refinement by setting it to something like .5 or .3 to compensate for the lower shadow quality

Looking at your second image, I think the reason your caustics are too strong is that your glass mesh is too faceted. I imagine you have it set to “set smooth” and you also added subsurfing… correct?

Yupp you are right, the glas is a cylinder with subsurface-modifer and i set it smooth.
Did i made something wrong?

@Lord of the Rings Junkie and frodo2975: Thx for the tipps, but at least i have rendered about 300 frames, but before i start it again, iam going to finished this render first.
Then i’m going to try some of your suggestions.

The caustics on the cup are really great,you should be proud of those caustics