Yafray error using Ubuntu 8.10 Intrepid

Dear all!

After having intalled Yafray I get following error starting Yafray

Traceback (most recent call last):
File “<string>”, line 1, in <module>
File “/home/who/.blender/scripts/blender/yafaray_ui.py”, line 25, in <module>
import yaf_export
ImportError: No module named yaf_export

Does anyone have an idea how to fix that? Thanks!


You should have a yaf_export.py in .blender/scripts or .blender/scripts/blender
as well as yaf_light.py

Did you build from source or install a .deb ?

Dear organic,

thanks for your reply.

I installed from deb Package ‘yafaray_0.1.0.282_amd64.deb’ and unzipped all files from ‘yaf_blender_282_amd64.zip’ to usr/share/blender/scripts/blender/

So all files including yaf_light.py, yaf_export.py and so forth are in usr/share/blender/scripts/blender.

What could be wrong here? Do you have an idea?

Looking forward to hearing from you soon.


I believe the contents of the .zip file should be in home/who/.blender/scripts

Dear organic,

oh, … stupid me. Sorry. I will give it a try, coming back to you soon.


You could run them from there. If you could go to Blender’s User Preferences and change the default script path to usr/share/blender/scripts/blender, but there are other scripts in .blender/scripts that you then wouldn’t have easy access to and it is simpler to have just one scripts location.

Are you using Blender from the Ubuntu repository, or the blender.org official download? There is another .blender/scripts folder with the official version, so if you have both the default scripts path will depend on which version you are using at any one time. It might be worth setting the default scripts path yourself to one or the other.

You can do this in User Preferences, then hit CTRL+U to save the user defaults.

Hi organic,

I set the path to .blender/scripts/blender.

All python scripts are in .blender/scripts/blender. And I am using Blender 2.48a from the blender.org official download.

Unfortunately yaf(a)ray does not work yet.

The referring python script appears in the pop-up from the script window, but when I start it, I still get the message, that the same python scripts are missing.

Do you have an idea how to fix that?

thanks for your reply.


Hi organic,

… now I reset the scripts path to default. Now it works fine!

Thanks for your help!


Glad it works!
You’ll love it.