Yafray GI - spotty shadows

Hello, I’m hoping you all can help me. Here’s part of a scene I’m working on:


I’m rendering with Yafray GI, all the light is coming from a SUN lamp (and a little coming from the world/sky color, light orange). The problem I’m having is that the ceiling and trim, which are supposed to be a solid light brown are very spotty:


Now I realize this is all being indirectly lit, so I might be expecting too much, but is there any way to smooth that out?? This is my first time using Yafray to render, and I’ve been reading up and playing around with settings for about a week. It’s a lot better than it was at first, but I’m still hoping I can smooth it out. And if one Sun lamp isn’t enough to light this scene, what would you recommend for lighting, while keeping the effect of light coming through the window? The values are about right for the look I want to achieve, just not the spotty texture.

Here are my Yafray settings:

Thank you for your help.

Blender 2.41
Yafray .008

You may need to tune your photons.

See http://www.blender.org/docs/2.32_release/gituto/
scroll down to “tuning photons”

Try experimenting with a photon lamp and increasing/decreasing the photon

Try googling “yafray tune photons” (no quotes). Many links…:slight_smile:

Hope this helps

This PDF will probably answer all your noise questions, written by Jandro himself (in 2004):

Illuminating with YafRay

Thanks for the links. I had seen that PDF, but I had to read it a few times before I got it. I did discover one thing I was doing wrong. I was using a Sun lamp only, which apparently doesn’t shoot photons. So I used an area lamp instead and the results were much smoother for the most part. I did get some ‘light leaks’ on the edges, but that was probably due to poor modeling on my part. I’ll probably tweak some settings and render again, then put it all together in photoshop.

Thanks for the help.