yafray help

I just got yafray, and i looked at a tutorial of how to use it. I followed it perfectly, making sure everything was the same (except the model).

In the tutorail, they had a lighter, but mine was of a chess board.

When i renderd, nothing happend, then, my blender became almost compleetly non responsive, so i had to shut it down. Then, i decided to only use the king and queen in the render, but that had the same result.

Here are the peices i was trying to render, and here is the tutorial. Please tell my what i should be doing.


Pay attention to what the Blender terminal is telling you. Besides, take into account that Yafray renders may take longer than Blender ones, since they are completely different render engines.

What kind of material do you have for
the chess figures? It looks sort of like glass.

yeah, it was suposed to be glass, with a white and black tint. The black is kinda blue because of the world environment. If you guys have any other comments on the overall peice, please say what you think about it.

I tried again rendering it real quick, and it had all these loding . . . whatever. Is that good.

Im gonna be gone all day at a sailing regatta, so im gonna set it up, and leave it till i come back.

You should have a nice result, when you come back.

If the loader works, then it should work out. Since Yafray is still an “external” rendering engine, you obviously have to export the models, materials, etc. from Blender. You can view the progress in the Console and see, if the Loader actually works or not. You can also see if Yafray actually renders something, look at the Render Pass - it shoudl constantly produce . and sometimes #, which means that everything is going well…

On the other hand, Blender gets non responsive because you use Yafray from the Blender plugin - if you would start the render from the command line, it would act as a totally independent programme and you could use Blender during the rendering. But it is probably not a good idea as it slows the render down…

So, tell us if everything worked well!

Rendering glass with YafRay can take a very long time.
I’ve had render times in the 6 -8 hour range and that
was with only 4 glass bottles.

I suggest you use a different material like plastic
to start with. Then when you get the lighting right
then think about try another material.

Looks like you have a checkered plane with the
chess figures on the plane floating in blue space.

That’s not really the right way to set that up.

its realy just the chess peices i want to see, so about it just being some peices on a checkerd plane, i know that.

I left it from 7:30 am to about 7:20 pm, and when i came back, i got a runtime error, which then when i hit ok, blender compleetly shut down?.

Is this a problem with my rafray or with blender, or with my computor.

Hi :slight_smile:
It’s not easy to say what the problem is because
you haven’t posted the blend file or told us your
computer specs.

comp specs:
-Screwd the f*** up

il post the blend file now. Dont wory bout the extra plane, it was there incase i wanted to use a different chess board, but i never found a good pic.

could anyone suggest a good file sharing sight. I found one but i dont know if it will work.

here is the file (might not work)

Try rapidshare.de, for single files it definitely works great!
Your link didn’t work =/

And yeah, your problem sounds a little strange, indeed…the blend will definitely help to find the problem.

ok, rapidshare isnt working for me either. Do you think it could be due to firewall restrictions.

EDIT: ok i found this it was different from what i first was trying, and i hope it works. Here is the link

Hi Guitarplay,

Did you uncheck the ‘xml’ button on the ‘YafRay’ tab? If you have xml turned on, it renders without the pluging, meaning there are no updates until the render is done. Without xml you should see things happening pretty quickly.

About the hour-long renders, start out with small renders and border renders to see how your lighting is turning out. Even a desktop sized render should be doable within 15 minutes with the right settings.

Have fun,

Wybren van Keulen

Hm I just downloaded your file and gave it a try. I see you did uncheck the ‘xml’ button. So that’s not it…

It rendered fine here, but the rendered picture turned out black… Very wierd. I decided to go down the elimination road and finally got to the ‘Hori’ button in your world setting. It seems to be messing up YafRay, because when you uncheck it, it renders fine.

Another thing is that I wouldn’t go for a subsurf level of two for setting up your lights, it takes the loader a lot of time and the models are quite high poly already.

Have fun,

Wybren van Keulen

its not the time that the render takes that is annoying me so much right now. Its the fact that it just does not work I have sailing 1-5 every day so if i know somethings gonna be a while, il work until i leave, and come back to a render. Hell, after that 2-3 times a week i work until 9:30, so i can give my computor 8 and a halp hours to do something(plus i have a realy slow computor)

i know its high poly, and as i was thinking i realized that, but i dont think that would cause a runtime error. Maby more time to render, but a runtime error?

Do you think you could render it again and show me what it looks like. I would like to see how much of a difference it realy makes. Oh and if you didnt notice, i fixed the crown of the king. I realized after i posted that it had been streched when i was sizing the model.

Hey could you upload your file here?
I’d like to download it and take a look.
If you do then just post the search ID number.


it wont work. It does not allow .blend files. Do you have a problem with rapidshare?

use http://www.zshare.net


ok, zshare isnt workin for me right now, but here is something new i added. Can you help me with a beteter marble texture.