Yafray: Lamp Radius Crashing Blender?

Anyone know why when I change a lamp radius then try to render using Yafray, Blender locks up? I was following the examples in the below link and when I got to changing the sample and radius then render it just locks. I later tried to just change the radius and it too locked up.


Any help is greatly appreciated.

I just tried restricting it to use only one processor and it renders. Is this a known issue? I would hate to have to use only one processor to render.

Looks like 2.44 is a bit more stable with Yafray. Area lights no longer crash when size is changed.

The bug is still in place. I got the same problem with Blender 2.45 and Yafray 0.0.9 (Pentium IV optimized version, the system is Windows XP). If I set a lamp’s radius more than zero, then render window just locked, as well as Blender itself. The system load was 100%, but nothing happened, so all I could do was shut Blender. Thanks for the tip with reducing the number of processors, it worked for me too.

I agree with the previous poster that using only one processor for rendering is no good. I thought it could be something wrong with the Yafray version I had, so I uninstalled the “Pentium IV optimized” Yafray and installed the general one (0.0.9, Windows). But the bug was present in that version too. Blender still locked up with a Lamp radius > 0 and number of processors > 1. Any tips and tricks to solve it would be much appreciated.

Not all the yafray code is multi processor compatible AFAIK, the same happens with DOF I believe. This can be also a bug.