Yafray lighting problems.

I already posted this in the WIP forum, but somebody suggested that I move it to here. Unfortunately, I don’t know how to move or delete my post. :o

I’m working on a bedroom scene. All of the models and textures are Steohawk originals, but unfortunately, so is the lighting. It sucks photons. :eek:

I’m using Yafray with GI. I’ve got a fan light that emits at 1, and “attached” to it are 3 area lights that point in different directions, each parallel to the floor. Each light has a power of 10, and the radii are adjusted to extend just beyond the walls. Other than that, the lights use default settings.

I’ve attached 2 pictures. The first is a render at 640x480 with no OSA. It’s a lot darker than I want, and the light is a bit “cloudy”. Also, notice how the green carpet doesn’t merely reflect a little bit of green on the wall. It completely turned the white fan blades green! The same goes for the purple sheets, which made the walls a bit purple.

The second picture is of the Blender window. It shows top and side wireframe views of my scene, with the three area lights selected. It also shows my render settings.

Thanks in advance,
Steohawk.

Attachments



Arealights energy should be = 1
control lighting power with “Exposure” and “Emitpwr” in the render panel

Thanks for the tip. :slight_smile:

I substituted my 3 high-powered area lights for 1 point light at a power of 1. I adjusted it’s radius to 30. The scene was bright enough, so I didn’t have to fiddle with exposure or emit power. I increased the photon count and radius, but there’s still a little bit of “photon funkiness”. Should I increase them even more, or is there another setting to be adjusted?

I intended to use ray shadows on my lamp, but it made my entire scene turn black. I tried adjusting the samples and radius of the lamp, as well as the gamma, exposure, emit and GI power of my scene, but none of it worked. Maybe I just didn’t do enough adjusting. What should I have done?

I’ve included my latest render, along with a picture of my render settings.

Attachments



A point light with ray shadows enabled and radius > 0 is in fact an spherelight, a sort of spherical arealight, so rules for arealights when photons enabled should be observed, which are light energy = 1 and control of spherelight power with “emitpwr”

Besides, the radius of the spherelight uses in fact Blender units, so it means it shoud fit in the scene.

Using Exposure should help to adjust the lighting of the scene.

Here you have an example of photon map tweaking:
http://www.yafray.org/forum/viewtopic.php?t=1120

Thanks for the help, but ray shadow still won’t work. I think I might be experiencing a bug, because I tried a test scene too. I tried to light a simple wooden cube. Without ray shadow, the cube is nice and bright. But if I turn it on, it’s pitch black. My scene is surrounded by a cube, so I know that no photons can escape.

I used the following settings for my point light:

Distance = 50
Power = 1
Ray Shadow = On
Samples = 8
Radius = 0.5

My render settings:

Shadow = On
Ray = On
Radio = On

My Yafray settings:

Ray Depth = 5
Bi = 2
Gam = 1
Exp = 10

My GI settings:

Method = Full
Quality = Medium
Depth = 3
Cdepth = 5
EmitPwr = 100
GI Pwr = 1
Photons = On
Count = 100000
Radius = 0.5
MixCount = 150
Tune Photons = Off

Output from console:

Shot 200000 photons from each light of 1
Stored 2599
Pre-gathering … 2436 OK

Edit: Where can a find a sample .blend file that uses ray shadow? Maybe I can use it to rule out the possibility of a bug.

The number of pre gathered photons seems to me too low. Photon mapping is scale dependant, what units have you used for your room?

Also ‘Emitpwr’ is too high, YafRay usually delivers good results tweaking just a bit the render settings.

There is a examples compilation here, although I don’t know for sure whether there is a good photons scene included, probably yes:
http://www.yafray.org/forum/viewtopic.php?t=1009

Search through this thread too, there is many photons scenes to dowload:
http://www.yafray.org/forum/viewtopic.php?t=825

The test scene uses a cube to keep the photons in, which measures 16.903. It uses a basic black material with no reflection, specularity, or ambiance. The wooden cube measures 2. The light is between it and the camera.

Apparently, I forgot to put the light inside the big black cube last time, which is why there were so few photons stored. lol. I corrected it, so here’s latest console output:

Stored 200179
Pre-gathering … 149889 OK

Even after this correction, it’s still pitch black. BTW, I intentionally used an extremely high Emitpwr to rule out the possibility that it just wasn’t high enough.

I checked out your horrible2.blend, and it rendered perfectly. However, I noticed something unusual. Around your sphere light, you actually had a sphere. I appended your sphere to my test scene, put it over my light, and it worked! I didn’t know anything about this until now. I just thought that the light would work on it’s own.

Thanks for the help. :slight_smile: