Yafray Lighting

Im trying to get yafray to work since it renders faster, better, etc. But everytime I try to render with Yafray the background is black and you can hardly see anything even with lights set to 10 power right by the objects. Any idea how to fix this?

In the “World” menu, you can change the background as you wish - including adding a sunsky, or HDR image. Actually, at present, most of the finishing is supposed to be done in the script window AFAIK.

Edit: Ugh! Please ignore this reply. I was in a hurry, didn’t read your post properly.

could size everything down?

Your remark about “lights set to 10 power” seems to make clear that you use Blender’s lamp buttons/sliders to adjust the light setup. That’s not going to work, as the YafaRay exporter does not adopt Blender’s light settings.
You have to adjust lights in YafaRay’s python interface instead:
Select the lamp, switch to “Objects” tab and change light type and intensity. In general: YafaRay lamps need a much higher intensity than Blender lights.

See also here: http://www.yafaray.org/documentation…objects#Lights