Yafray Problems

Hi im new to this site and I know a little about Blender. I am having problems with getting Yafray to work. I work on Mac OSX with the intel core 2 duo processor if that helps in solving the problem. Everytime i try to render with Yafray the screen is black. I have read several tutorials and tried to reinstall python, yafray, and all that jazz, but still no luck. I would appreciate any help! Thanks everyone!

Try making your lights brighter.

Thanks! Yeah i tried it and it didn’t work…i know…ima noob…sry, but im trying, Yafray doesn’t show up in my render options and iv’e tried to reinstall everything and change my scipt paths and all that, but still no luck. Any ideas? Oh, and I installed Yaf(a)ray because i was told that Yafray is as of now inoperative. So technically I should be saying Yaf(a)ray doesn’t work.

That could be it…

Can you show a screenshot of the render button you used to get a black render ?

Yafaray is different than Yafray. With Yafaray you have to go to render and then render to Yafaray 0.0.3 or whatever number it is. This is a python script to access the renderer. Keep the render option as blender internal. Go to Yafaray.org and download the pdf guide it is still good and the wiki is being updated. The Yafray option is going to be gone in 2.50.

Happy Blending;

use the tests scenes: