Yafray render crash PLS Help

Hi
im quite new to blender so my problem may be a minior one but it makes me go insane.
I installed the newest version of yefrey a few days ago my blender is the newest version as well.
After making some basic stuff i decided to do something more comlicated with yafray so i created this render:


then i decided to have some caustic effects in there as well.
i tried it with tree photonlamps one for each color red,green,blue and placed them into the existing pointlights. i set the numper of photons per lamp to max wich was too much so yafray crashed during the render with a reduced number i got grainy caustics.

Then i tried to have four photon lamps per color one for each cube for all colors in blender this looks like this:


each photon lamp emmits amout 1500000
photons wich i found was a managable ammount. i tried that with a single cube and it worked.
but with the setup like in the picture above yafray crashes again during the render with an error message saying “could not find yefray is it in path?” diplayed in the console.
The crash does not come right at the beginning at first all goes as planed the light is calculated and then the shooting of the photons begins. it all goes well untill the 9th photon lamp then the error is displayed.
a way to solve this s to turn down the ammount of photons but then the caustics look ugly.
As i mentioned i have the latest versions of yefray and blender my OS is Win xp prof with sp2 and all other updates my system consists off a CORE 2 DUO 2.33GHZ T7600 4MB 667MHZ, 2GB ram, 7 GB of virtual memory and two g-force 7950 gtx in sli mode.

Is the decrease of the photon ammount the only option i have or is there another way??

I hope my discription is not too long
thanks for patience.

“could not find yefray is it in path?” diplayed in the console.

There is your problem, Blender cannot find Yafray. Completely uninstall Yafray, delete all its files and especially registry keys. Then reinstall. If you rename any of the files or folders related to Yafray, or change its path after installing it, it will stop working.

i didnt change anything and as mentioned i can render with yafray with nice caustics but only in a simple scene with one cube but when i apply the same settings to the scene with the four cubes it crashes.
that is my problem blender finds yafray but when rendering a scene with many photons it crashes.

Well if that’s what it said in the console, that’s what blender thinks. Try rendering just the default cube and see if it works.

Why the error shows up, if you can render with Yafray is strange. But a small advice: don’ overkill it with too many photons. Try lowering the amount and play with other parameters, brute force isn’t the best way to get results. In photon lamp settings, there are few fields, you should change from defaults. First, tune the Blur value, default 0.01 gives very sharp caustics, increase it until you don’t see the flacks, but overall effect is sharp enough. Then, also Search param is important, increase it, based on overall photon count. Maybe 300 000 - 500 000 photons from each of your photon lamps (you have 3 of them, right?) should be enough for quality render.

Here are some very quick and ugly tests to demonstrate the Blur parameter (Blur: 0.01; 0.08; 0.2; 0.5):

Attachments





well that helps a lot
i dint know that the bulr effect looks so great i thougt it is just an option to have some very final tweaking but your render with 0.08 looks great, a lot more realistic than my try with a single cube and 1500000 photons.
Thanks for the advice ill try that.
maybe i can show the final result here soon

hmm ok
i reduced the number of photons to about 900000 per lamp. but the result is this


my test cube with nearly the same settings, blur was turned off, looks like this



the good thing is that it works but that is not the way i want it to work

just for explanation there are three normal lamps one for each color red green blue, to create a caustic effect of every color on every cube i put four photon lamps per color in there makes a total of 12 photonlamps you can see that in the blender screenshot i posted above.

Why are you using 900 000 photons from each of 12 lamps for test renders? That is unnecessary high number. lover it to max 200 000 per lamp (that is still high, can be considered final high res setting) and try out. Do you want ot get dispersion effect, so you are using 3 separate lamps? If this is the reason, then Yafray can handle the dispersion for you.
Look into settings in Blender and read the documentation and tutorials or search the net!

at first this render was not supposed to be a testrender it was planed that the caustics give the picture a final kick. but then it crashed during the renders.
im not looking for dispersion, although its a nice effect i want the three diffent colors to produce their own caustics. i hope that due to the fact that the three colors are not emitted from the same location the produced caustics will create some nice effects.
Just while im writing this the render running on another pc crashed again with the one-cube scene i posted above i think its because i set the floor to full reflect maybe thats too much for yafray or blender. can i set the floor to be non reactive to photons?

You aren’t doing any tests? I don’t know how much memory take 10 million caustic photons, but it is large I think. I advise you to do some tests, don’t consider any rendrer final until you tune the settings on some lower quality tests. Have you read what I pointed you at? Really, lover the amount of photons, hundreds of thousands are enough for most scenes.

I don’t know how to set any material to be undetectable for photons except turning the Traceable button off in its settings. And have you seen any caustic patterns or texture on mirror? I guess no. If you set the ground to perfectly reflect environment, you won’t see anything on it except reflections.

Yafray writes some useful info in console. Look at pre-gathered and kept numbers of photons, that will tell you if you aren’t wasting them. The example I posted used total of 600 000 photons, but only about 20 000 were kept. Very unoptimized scene.