Yafray render is always cloudy

I have a model of a room which whenever I render using Yafray it comes out cloudy.

The tutorials on yafray’s website say the solution is to increase the photon count, but it seems to make no difference. I 've tried high counts, and low counts. Even changing the radius setting doesn’t help.

Could someone be kind enough and point out where I’m going wrong?


If you are using photon lamps my question is why? you can get a better non cloudy render without them the only reason really to use photon lamps is for caustics normal lighting would work much better for a scene like this.
That’s if you are using photon lamps im not sure if you are.
If your not maybe theres a texture you have or something im not completely sure whats wrong with it.

Hope that helps.
Nice looking scene btw.

GI Quality is set to low. If you increase it will clean that up. Also you can fine tune the GI settings to increase quality. Photo LAMPS are not needed here, Photon lighting (in the GI pane) can sometime produce nice results. It depends.

Hi monofoso,

Many thanks for your response.

No I haven’t been using photon lamps as you’re right, they’re only needed for causitics. The scene consits of:

  • 2 spot lamps positioned far away and directed through each window.
  • An area lamp filling each window and directed inwards.
  • An area lamp covering the entire floor and directed upwards.

There are no textures on the wall, but the floor and ceiling do. The latter having a bump map.

The model is by no means finished yet, but your compliment is encouraging :slight_smile:

Having experimented some more I’m beginning to understand the finer points of the yafray controls. I still have some light leaks and artifacts that need correcting, plus the texture resolutions are far too low, and the mood of the picture isn’t quite what I’m wanting to achieve (I’m actually sat in the room I’m modeling - Who needs photo references? :smiley: ). I think the sunlight needs to be brighter and the floor actually needs a slight polished effect.

I’m going to be busy for a while it seeems…

But definitely much better than before:


Hi masterhoshi, thanks for your response.

GI quality was set to ‘High’ in the 1st image, and I had tried playing around with the quality settings too. It was probably the wrong combination of settings though.

For the 2nd image I have turned off ‘Photons’ in the Yafray GI panel which has reduced the ‘Cloudy’ effect but has also reduced the warmth from the image.

Like I say I’m still experimenting :smiley:

I’ve found Yafray tuning to be an art in itself. How long does your scene take to render, btw?


Check that tut out, they have your exact problem with the bloches discussed and solved.

Yes it’s definitely an art masterhoshi, and so is the rest of CG modelling! Many more brick walls still to knock down, and still a few strands of hair on my head to be pulled out :wink:

I can’t remember the render time of the previous image (I think it was approx. 6 minutes), but the one below took 9 minutes to render at 720x576, OSA 5. This is on a Intel Centrino 1.6GHz, 512MB RAM laptop.

Now that I’ve added a true reflection to the TV it’s added a chunk of time. And as you can see Yafray’s doing something wierd to the edges of the screen.

Knum, that tutorial was one of the first ones I found. Reading over it a second time has helped highlight some settings, so thanks for pointing it out to me again :slight_smile:

Ok so the latest render…
I increased the spot lights to 10 to create a better looking sunlight. Still very low resolution textures, so ignore if you can. The view is part of the same wall and the wall opposite the windows. The rest of the appartment isn’t modelled yet so the hallway (through the doorway) and kitchen (through the square arch) are missing. I guess when I glue these on it will make a big difference to the lighting.