Yafray Rendering Problem

  1. I know this is probably me doing something really stupid, or not having done something really obvious but I’ve rendered over and over again with changes in Photon Count and Radius and all that and can’t seem to get it to work.

Okay, normally I’ve been rendering in YafRay with Full GI and Photons with a GI Power of ~1.5 with high powered lamps. After attempting to get caustics working for a still I’m trying to render, I decided to see what kind of result I would get with a more powerful GI value, and lower lamp settings. Caustics now work, but I have an incredibly noisy image now when I render and I’ve changed the Photon Count to random values everywhere from 1-50,000 with the same kind of results, and changed the Radius value from 1-5 and still it’s noisy.

  1. Also… I need a way of allowing light through a plane with a glass material to use as a window.

Any help is much appreciated.

Sample Images:

#2 Yafray cant do that yet. The work around is to render 2 shots one with glass one with out and combine them or put a lamp on the side of the glass you want lit.

I still don’t get why all people think global photons are a universal remedy…

Again some facts:

  • Photons are in general only usefull if they have good chances bounding multiple times at nearby spots (read: indoor scenes), otherwise simple path tracing techniques are always easier to setup, and most likely faster.
  • yafray’s photons only really work as intended with area lights, preferably large ones, and most notably NOT with image based lighting (yet)!
  • global photons do not produce direct caustics, they only aid to indirectly sample caustics from area lights

In other words: Disable photons for a car parked outside, and use irradiance cache instead.

Neither scene is outside. The top one is in the room of a house (although I know you can’t see that), and the second is a car in a cube which was actually a temporary setup. For and outdoor scene I wouldn’t use photons.

I’ll have to look up this path tracing thing though. Thanks I’ll go change the lamps to area lights.