Yafray started to crash Blender

everything went fine until at one point Yafray started to crash.
the point is all seems to be fine with Blender rendering in Yafray.

This is the crash log. all images are there so I do not know whats wrong!

any body can help me?

Host Name: Claas-Kuhnen
Date/Time: 2007-01-14 23:33:42.459 -0600
OS Version: 10.4.8 (Build 8L2127)
Report Version: 4

Command: blender
Path: /Applications/blender/Blender.app/Contents/MacOS/blender
Parent: WindowServer [55]

Version: 2.42a (2.42a, 2006-Dec-30, Blender Foundation)

PID: 543
Thread: Unknown

Link (dyld) error:

image not found

the best part is that i can locate which object it is be putting it onto a different layer.
However when I render that layer alone it works. Crazy. But with all objects toegther
it does not!!! hello?

What sort of object is it? I came across a similiar problem with an object that had been heavily booleaned. I think I finally had to delete the object and re-build it.

Maybe you could isolate the object and post the blend file with a bug?


  1. Does Blender render that scene ?
  2. Can you export and render a XML version ?
  3. Did you isolate the object that is causing the crash ?
  4. Can you reproduce the crash in another scene ?
  5. After testing these things, if you conclude that it is a bug, report in the yafray forums please, since the yafray bug tracker is not that active. :slight_smile:

When ever I try to use yafray, it crashes. Do u have to use xml code?

that is so wicked.

ok i added a lable to an object. all rendered.
than i added a new object and created a semi translucent shader and it crased.
now matter.

the console told me after exporting the geometry yafray just kills blender.
no matter if XML is on or off.

so there was an issue with the image.

so i separated that object and alone on a layer it worked fine.
rendered together it made blender crash. hello ???

what i did was do kill the texture because reloading the image file ect
did not do anything.

i created the a material again applied the image file and all works now.

so funny, i have the same scene again, some textures but it works now.

crazy …

cekuhnen…I’ve experienced such problems myself.

I even asked about it here already but got no reply - probably because it is just too weird. My problems usually start when I start to duplicate a lot of things, especially objects which are parented to lattices or other meshes. Funny enough, when I copy the copied objects, it often works again…

As Alvaro said, I tried to narrow the problem down, but I simply can’t. Rendering these objects alone usually works, while rendering them with other meshes causes a crash (even though they render fine alone…even with other meshes). Also, sometimes the problem can be solved by restarting Blender.
I know that it does sound crazy but since you have experienced similar problems - I felt like I should post mine as well.

restarting blender did not do the job for me.

but deleting the texture and rebuilding it worked.