Yafray Testing

hello, this is my first real post on elysiun. after a bit of a struggle, i’ve managed to get yafray up and running, and i’ve been running tests like this one all day. so far i love blender/yafray and the direction they’re both headed (such rapid development recently!).

a couple of questions:

  • why doesn’t the pink sphere cast any light even though i’ve set its ‘emit’ parameter very high (the slightly lighter area on the left hand cube near the sphere is not receiving illumination, that’s the effect of radiosity) am i missing a parameter or can objects not act as area lights in yafray?

  • some insight into what’s happening with the photon’s? i’ve got three lights in this scene, all occupying the exact same position, pointing in the same direction because they’ve been tracked to the whiskey glass. an wide area light to provide gentle illumination, a photon light (is it too strong?), and a spotlight with a clear path to the whiskey glass (why no specular highlight?). the lights are located above and behind the cubes.

all comments appreciated to help me resolve this. thanks. :smiley:
http://srv.fotopages.com/2/2874374.jpg

ps., the jpeg artifacts are not mine. fotopages introduces them when they resize an uploaded pic. %|

About the pink sphere… Emit does not actually make things emit light, it just makes them look like they are.

so is there a parameter to make an object cast light?

No. But you could add a Lamp in the location of the object and set it to Sphere and mess around with the distance parameter. Or you could use the object with radiosity, like you did with the cube.

Perhaps the Spec setting on the glass is too low? Or maybe your Lamps are set to No Specular? [Edit]Never mind about that; I did some quick renders and Yafray seems to ignore that option.[/Edit] Try increasing the Spec and decreasing the Hard to make the specular highlight more visible.
Oh wait, you said you put the lamps above and behind the cubes? That’s probably not giving you the right angle for a specular highlight…

The photons look fine to me; I don’t see anything “bad” happening to them…

Welcome to elYsiun, by the way.

It looks like your photon lamp is too strong, it doesnt match the overal light level. Maybe add more photons, and increase the blur.

okay, i fiddled a bit more with the photon light and adding more photons and blurring them seemed to work.

i’m a little disheartened to hear that objects can not be made to cast light. one of my favourite tricks with my commercial software is to make my lights out of cubes, and set one face to emit light. the cubes then can be scaled to any dimension and mimic the traditional ‘soft boxes’ found in photography studios. i guess the solution would be to use an area light in conjunction with the cube.

thanks for the welcome, DVirus. cheesy as it sounds, i look forward to contributing in a more substantive manner to this fine community. :Z zorro!