Hi all,

I just have a quick question…I keep trying to do a test render using yafray. All I get is a black screen, and nothing…I even just made a small simple scene just a square and plane…I changed to Yafray and hit the xtml or whatever its called and still just a blank screen after 20 minutes and I finally just cancelled it. Does it have to do with my PC memory/Speed?


yafray can take a long time to render, but you should be able to see its progress in the command console. also remember that generally you will need to turn the lamp/lamps to a higher setting than you would with the internal raytracer.

And, instead of lamps (or rather together with lamps), you can use Global Illumination – when you switch to YafRay Renderer, you get two new tabs: YafRay and YafRay GI. In the second one change Method to Full and Quality to Low (or better if you have time:)).

There are also 2 Power sliders there, which you might want to up a bit.

I am not sure what they do, but it looks like they scale light power or something. Its easy to get a completly white render though.

Ok, I admit this is probably just a noob issue, but I’m having the same problem. I have Blender 2.36 and Yafray 0.0.7 (On Suse Linux 9.2 if that makes a difference)

I am trying to make a very simple test render just to see if everything is working, and all I get is a black render window. I too have left it go for a long time but nothing ever comes out.

I tried following the instructions above (about light intensities, global lighting, photon counts, etc), but none of the changes seem to make any difference.

Is there a sample blend file somewhere with an appropriate yafray setting so I can at least be sure my installation is setup right? Then I can go and look at all these settings in my test render knowing I at least have the basic configuration.

if you could post what you get the inconsole it would be much more helpful.

there are a couple examples here, but if someone knows of a place with an explanation of the physics of light and caustics in yafray, it would help me understand it a lot.

I gave up using the internal Yafray renderer. I choose to use Blenders then load the picture up in DogWaAffle and add a tiny bit of noise. Voila, Yafray.



Again, sorry for being such a noob, but where/how do I get to the console?

Thanks for the link. I have decided there is officially something not right in my installation, but its too late tonight for me to diagnose it. Maybe tomorrow I’ll have some insight.

The samples come up the same way, render screen is blank/black.

For Yafray, has anyone else done the install using the rpm file? Maybe I need to compile it locally?

Just start blender from a terminal, and see its output.


The ‘xml’ button will suggest yafray to render in background, its better you turn it of for such small renderings, this will allow you to see the progress in the rendering window.

I suggest you read the yafray documentations here at,i t will definately help to remove some of your problems.

The black screen can be a result of many problems, first you must check if yafray dosent crash on your system, in most cases the whole blender will crash, if not then you might see some output in the’ terminal window’ that sprang up when blender was started.

As far as i remember suse9.2 installation of yafray worked fine for me.

If you do compile yafray then you must compile blender from the same machine to get them working fine. If you still have problems send me the sample blend fine and I will check if for you. :slight_smile:

Download the official sample files for yafray from here


Ahh, Thanks I was not thinking in a logical Linux administrator mode, rather was trying to find a command console option within Blender somewhere. (e.g didnt think simply enough)

Running from the shell gave me the answer right away! I was missing my export directory for Yafray. Its slow to render, but it appears to be working now. Took approx 8 minutes to render.

BTW - is this normal render time for this test corrnell.blend on a Pentium M 1600Mhz?


Yes its is pretty much the normal time, its is slow as it is using caustics. And dont worry for other things than GI, Yafray will be faster than blender in most cases. :slight_smile: