Yafray

OK, just got Yafray up and running on the computer and started experimenting with caustics.
Now why does it look like this, that ring is supposed to be made of glass?

Attachments


First of all transparent objects in Yafray must be set with the alpha value set from 0 to a value less than 1 based on the transparency level you want. Second, use photon lamp with a higher number of photons (200000) and use the blur parameter to get a better result.

Enjoy.

could you supply your .blend to see your settings?

Could it be that the normals are fliped to the inside?

Here’s my .blend file and image.

Attachments


Here’s my .blend file and image.

http://www.geocities.com/spacebias/YafrayTest.zip

Attachments


ok is this something like what you were aiming for?

Attachments


or this: (which is a little lighter)?

Attachments


I was aiming for something like the second one.

Ok well I made quite a few quick little changes and I can send you the .blend via email but I don’t have a filehost to host the .blend right now. So you’ll have to give me your email address to get the .blend. The main change I made was I changed the reflect value for the ring down to .183, then I changed the absorption to green and lowered the alpha to around .118.

Oh I almost forgot I turned the translucency down to 0 also.

I also forgot I turned the photon light from 250k photons to 500k and turned the blur from 0.030 to 0.050 so you don’t get any graininess for the caustics.

Also I turned the cache on and turned the shadow quality up to 0.94

See I made so many quick changes I forgot what they all where so I suggest getting the .blend from me and studying the changes.

Ok, I reinstalled yafray 0.0.8 and opened your file and hit render and it worked fine, only thing I changed was from “2” processors to “1” processor. Not sure if that would cause your problem, not sure what you have for equipment.

Attachments


That’s funny I have yafray 0.0.8 and it came out black on mine till I made the above stated changes. I forgot to change the processors from 2 to 1 even though I only have 1 but that made no difference at all. I tried it with 1 and 2 processors and it rendered exactly the same and even in the same amount of time. I guess it just doesn’t use a 2nd microprocessor if you don’t have 1 :wink:

so you got it to work then??

Are you asking me? Or the OP? If you’re asking me, that depends on whether you’d consider this as working or not: If you’re asking the OP, I too wonder where he went and if he is going to give us an update on how it’s going.

Attachments


I ment space.warp, sounded as if he did get it to work, just wanted to be sure. =)

Oh ok cool, yeah I was wondering the same thing, did he finally get it to work and forget to thank us or did he just give up and switch back to blender internal renderer? lol

Hey I redid the lighting as HDRI and I think it looks a little better, whadya think?

Attachments


yah, looks much smoother for sure. How exactly DO you do an HDRI render, I’m still figuring out yafray atm.

Well you click the world button (the little blue one all the way to the right) then add a texture as image. The texture you add has to be a .hdr texture, you can get those free online on some site which I can’t remember off the top of my head right now. Then you click angmap under texture and input. Thing is with a .hdr file you won’t see the image under preview. That’s ok though it’s there. Then you want to make sure you have Full GI on and turn up the photon count there.

Oh I almost forgot take away all the lights except the photon light.

Here is a tut on HDRI: http://www.tutorialized.com/tutorial/Blender-Yafray-HDRI/5816

here is the site with .hdr files free for download:
http://www.debevec.org/Probes/

Hi, just got back.
[email protected]

It’s NOT working.

Finaly, I got it working by updating my Blender version.

Attachments


just out of curiosity, what version of blender were you using? and what version of yafray did, do you have installed? :slight_smile: