yafray

I want to use Yafray, but the option doesn’t appear in the render menu.:s
I don’t know why, but it might have to do something with python, cause I don’t know how to install a full version of Python either.
When I start up Blender I always get this message:

compiled with Python version 2.5.2.
‘import site’ failed; use -v for traceback
Checking for installed Python… no installed python found.
Only built-in modules are available. Some scripts may not run.
Continuing happily

Yes, u need to instal python (2.6.2), this is very simple. Go to this site:


Download installer for your OS, and simply execute the installer and follow instructions. This should fix the problems.

Yafray development stopped years ago so is now obsolete and removed from blender. Replaced with yaf(a)ray
Do a forum search here for yafaray to help you prevent common mistakes when installing it.
http://www.yafaray.org/community/forum/viewtopic.php?f=13&t=2423

Richard

In case you still do want to use the old yafray (and not yafaray) use blender version 2.48. That is the last blender-version that supports it. Yafray might be a bit easier to handle, if you’re new to that kind of thing, as it’s integrated into the normal blender-interface. Still, I’d recommend learning Yafaray - It’s more up to date, it’s fast as hell (if configured correctly), it will see ongoing developement in years to come and - last but not least - it will surely be supported in the magical upcoming blender 2.5!

I installed yafaray, and it now appears in the render menu.
But it still doesn’t work. When I click it, I get the error: “Python script error: check console”.
I think it has to do with the fact that I use a built-in version of python and not the full version.
See my previous post.

Could maybe someone tell me how to install a full version of python? I allready tried it, but it didn’t work.
I downloaded the file from the python site and I installed it, but how do I make blender see that I have installed full python version?

Ok, searching through the forum I found out that blender doesn’t support python 2.6 yet, so I installed python 2.5. I now tried yafaray, but it still gives the same error: “Python script error: check console”.
When that didn’t work, I checked the command screen that opens together with blender, after trying yafaray, this appeared in the screen:

ERROR: importing yafqt failed, qt GUI will not be available:
Traceback (most recent call last):

...

some file paths

import _yafrayinterface

ImportError: module use of python26.dll conflicts with this version of python.


The error speaks of python 2.6 allthough I installed python 2.5.
Any help?:s

You need the same version of Python for Blender and Yafaray, which depends on the Operating System you are running on.

So for Windows and linux 2.6, and for Mac 2.5.1
http://yafaray.org/download/YafaRay

EDIT - Yafaray 0.1.1 will only work with Python 2.6(on Windows and Mac), so you will have to use Blender 2.49

Read what it says in the console window. You need to install the correct version of python. This will most likely either be 2.5.2/4 or 2.6 depending on your version of blender. It tells you in the name of the blender installer you downloaded and in the console window. Install the correct one and the make sure it matches in the version required for your yafaray install. They NEED TO BE THE CORRECT VERSION FOR BOTH. Install from python.org.
Read the link in my previous post for common errors when installing.
Richard

well in the blender console it says: “compiled with python 2.5.2”, and it says: “got it!”.
But when I look on the site of yafaray I see only the version 0.1.1 wich needs python 2.6.
What do I need to do now?

Blender 2.49b(the latest version) for windows is compiled with python 2.6
You can use that with yafaray also compiled with python 2.6

Richard

Ok, now I installed the blender version 2.49b, I have installed yafaray 0.1.1, and I have python 2.6 installed.
The problem is that blender doesn’t see my version of python.
Anyone who knows how to fix that?

You don’t have the right version of python for the version of blender you have installed then.
In case you are running 64bit windows you would need to install the 64bit version of python. http://python.org/ftp/python/2.6.2/python-2.6.2.amd64.msi

Richard

No, no, no…

There is no 64 bit version of Yafaray for Windows. You need 32 bit Python, Blender and Yafaray.

From yafaray.org:-

YafaRay 0.1.1 needs Python 2.6.2 installed. It will only work with Blender versions compiled with Python 2.6.
In Windows 64 bits systems, YafaRay 0.1.1 should be used with Windows 32 bits versions of Blender and Python.
Read these notes if you experience any problem.

pcforme go to yafaray.org, read the installation notes and follow them.

Thanks for all the help, now it works perfect.:smiley: