YAHE (Yet Another HDRI Experiment)

Yes, I know we don’t need more HDRI tests…
But I think this one turn out so good I just have to post it.


Actually, this one turned out pretty bad.

I mean, it doesn’t look like crap or something, but those lightdots on the floor and the spheres are too much and the HDRI is mapped incorrectly. That black curved ‘hole’ you see in the reflections is a result of wrong mapping.

Sorry dude.

Oops wrong word, what I mean is this I think it looks nice, regardless of the crappy mapping.

How did you get it to work correctly?

I have been trying to get it to work but here is where I’m stuck

When rendering with Yafray (i dont have any lights to make sure its HDR lighting). I end up with a render that is full of white spots. Its like very bad ambient occlusion on steroids.

Can we get an example, or even a blend file?

Can you increase the lighting? I can see some blobbly shapes but it doesn’t show up well.


What do you think is causing those light spots all over the floor? (and what do we do to fix them?) I’m noticing these abberations in my own yafray renders when I try to use hdr files for the world texture. that is, using just the hdr for lighting.

Sorry, I have no idea. I did quite some stuff with Yafray, but no HDRI-work. All I can say is that they shouldn’t belong there (as in not realistic).


I think it may be the specularity from the HDRI image, I’ve had the same problem, not sure how that can be fixed though.

They are there because of random sampling from the HDR image. What you can do, is download HDRshop from http://www.hdrshop.com/, open up your HDR map, and use the gaussian blur filter, with a setting somewhere between 10 and 20. This will smooth out the contrasting parts, and the random samples won’t have that much difference in ligting intensity, ie: no blobs.
Also: increase the quaility level to at least Medium, but preferrably High in the Yafray GI settings tab.

To get rid of the bloby spots turn the image filter to above 1 in the texture buttons, also you don’t have the HDRI mapped to be an angmap, on the world buttons change it to angmap mapping