z-axis is locked when rotating scene

Hi,

I was doing a tutorial and here: http://www.youtube.com/watch?feature=player_detailpage&v=-X5QGx2TP_8#t=538s author rotates the scene, so grid is displayed vertically and also is rotated. You can see on bottom left corner that z-axis isn’t aligned vertically.

I can’t do the same on my blender 2.66a default installation. Z-axis is always locked vertically and I can’t rotate scene the same way as author of that video does. What should I do so I can rotate scene “freely” without z-axis being locked vertically?

In the File / User Preferences / Input panel you have the option of changing the orbit style from the default Turntable to Trackball