Z-depth changes suddenly in values, please help!

This is how much the Z-depth changes from one frame to the other. As a result, I cannot use my Z-depth images at all.

Please help me solve this issue! It is very annoying.

You need to supply more info that that. We know nothing about the scene, how you created the depth map or what you change between each frame etc etc

The depth map was created by Z-pass into a Normalize node and to a File Output node, so each rendered frame also gives me a Z-depth map.

Nothing changes in-between the frames, except camera movement, and the camera moves only slightly between frame 148 to 149 out of 200 frames. That movement is so tiny that it should not produce so far different results.

Why do you normalize the z pass? Some tiny variation in the most distant visible object pn some edge of frame will produce heavy flicker. Save z pass directly and use that.

If I don’t normalize the z pass, the file will be just white. Just plain white image.

With a normalize node, I get the z pass that you see in the picture, with distance and depth.

Don’t normalize the Z pass. Never. That’s why you have that issue.

If you don’t normlize it, the image isn’t pure white but values are above 1, so you can’t see it but information are still stored.

The normalize node will analyse all the pixels and adapt the global range between 0 and 1. It means that if an object appear far far away, all the image will be adapted.

To grade your z pass, you can use a math node in multiply mode, or a map value node. Or even a color correction node and play with the gain but forget the normalize like it can be showed in many tutorials, that’s a huge mistake.

Thanks for the info.

Sorry, this issue has not been solved yet, sorry for the prefix.

I just tested it today, and my Z-pass image IS pure white.
I tried connecting it and playing around with the map value and multiply and even subtract node, but it only ranges from white to black when I plug the different nodes in. There seem to be no data about depth saved into the image, whatsoever.

(.blend attachment deleted)

Don’t use jpg format, it can’t store the value above 1.
Exr is the best choice for that.

How do you save in EXR format, when File Output node only allows for JPG?
I can’t change the file format in the File Output node!!!

It says “JPEG” and it is greyed out.
I cannot change it to EXR.


Sorry, I got it working now. I just had to change the file format in render tab/settings, then insert a new File output node.

Thanks for the help, the issue seems to have been solved now.

In the node property, or the render settings.