zblur plugin not working

Hello - I’m a newbie here so I’m sure I’m doing something stupid…

I’m using 2.32 on xp.

I’m trying to get the zblur plugin to work. I can get other plug ins to work (I downloaded a load of them from somewhere - think it’s linked here somewhere) Anyway - whatever settings I use, I can’t seem to see any blur when I render a pic. I’m adding the plugin in the sequence window and when I render I select ‘do sequence’…

Is there anything else I need to set or does this plugin not work on this latest version of blender?

Thanks in advance.

did you render with a zbuffer?

does it simply not work?
does it end up red?
is there any errors printed to the console window when you load it?

(and can you find this place, it may be a nice resource for some of us)

try rendering images of the type “Iris + ZBuffer”. this way, the Zbuffer is saved within the images, and Zblur can process this additional channel.

hope this helps

Thanks for your help - the dowload was from:


I don’t get any errors when I load it and when I load other plugins, they work so I don’t think I’m actually loading the plugin incorrectly - I apply it to a scene in the sequencer window.

I tried “Iris + ZBuffer” but that didn’t work…

Real newbie question - what exactly is zbuffer?

I tried the other method of depth of field - putting the camera on a circular path with one frame rotaion but I think I need to perfecty that method… It would be gosd to get the zblur plugin working though…

Thanks for you help.

it’s a place to hold information about the depth of each pixel. imagine an additional channel, like the alpha or any color channel. it’s more or less a greyscale image, where black is “close” and white is “far away”, or the other way round. “close” and “far away” are defined, if i remember correctly, by the clipping values in the camera edit buttons.

during rendering the zbuffer is calculated for various effects (shadows etc.) and stored in a portion of memory (buffer, hence the name). it is not a visible channel in the final render, but comes in handy for post production (if properly stored within hte image data), where you can apply various effects based on the stored depth information - you can clip objects or colorize the image based on the distance (e.g. desaturation of objects very far away), just to name a few.



I got it to work fine on 2.32. After you apply its strip, you have to select it and press N, to call up the plugin options… then set the focus number below 1 and turn off the Autofocus button.
You can apply this plugin to a sequence rendered as Iris + Zbuffer or to an unredered scene.