Zoom Rate is Too Much

Guys I am realy realy realy tired of dealing with this sh*t. Lets say I am close to an edge and I want to close more and then it suddenly jumpt too much. Do not say align view with “.” because when I need to select more than one element which are far away to each others, aligning view does not help.

What I want is that zoom rate should be decreased automatically when I zoom more to the ACTIVE element. Is there any way to do this?

Thank you guys.

Do you normally zoom with mouswheel or ctrl+MMB?

I find that for close-up work it’s easier to move around in Perspective mode than in Ortho mode. You can get much closer. Just use the 3D cursor to define where you want to be viewing, and then press Alt-Home to center your view on it.

Also make sure you adjust the camera’s clipping bounds to accomodate close-up viewing.

What do you want by saying “Use 3d cursor” ? Also what is “Alt home” ?

Also what do you mean by saying “adjust camara’s clipping”? Is it camera start and end clipping option?

One more question: Also I am having problem with rotating when I am closer. When I am close my rotation speed still fast. It is also a big problem.

are you in perspective or ortho mode ?

happy bl

Perspective. As I said, I want to adjust rotation and scrolling speed. It should be decreased when I am getting closer. I think what I am saying is clear enough.

There’s no need to be hostile to the people trying to ferret out your issue.

Like Anthony said, set your 3D cursor to whatever you need to zoom in on, make your selection, and press Alt Home. In perspective view, zoom speed slows naturally as you get closer to the focal point; pan/orbit speeds are tied directly to your mouse.

If you’re having an issue other than that, upload a video. We can’t see what you see.

2 Likes

Okey, thank you for your answer and I am sorry if I was a bit rude. One more question: When I select parts of windows of a building which are far away from each others and lets say I need to zoom to one of them while I select all of them and I also want to rotate around one which I selected. In this case since pivot point is center of all of them, it is hard to rotate around the one I selected. Is there anyway to fix it?

I don’t think it’s rude to ask questions or clarify answers. I think some people just don’t remember how hard it was to ask questions about Blender or understand the different settings when they first started out. I know I didn’t, and I still have much more to learn, so ease off!

SoftwareEnginer, the pivot point that your viewer pivots around is set by left-mouse-clicking anywhere on the screen (in the 3D viewer). It can be pulled off that point by using the mouse with certain keys, such as holding down the shift key while also holding down the middle mouse button and dragging. In such a case, you have to reset the pivot point with the 3D cursor again. Other than that, unless you’re in Ortho mode, you should have no problems.

Shift-F is change to fly mode, instructions appear in the task bar, this is where you have infinite control. WASD keys as fly with ALT key as slow speed modifier,

additional things to be aware of:
N-panel > View > “Lock to object” this is handy but locks some zoom functions ,

Normal walk mode:
Hold ctrl- then MMB scroll wheel is left-right, move mouse up or down is zoom, if you start with mouse high on screen it is fast, mouse positioned low on screen slower.
hold CTRL + Shift then scroll is rotation on perpendicular to view plane.

Poster needs to understand his lack of knowledge in blender is simply that, it is no reflection on his intellect,ability or value, some people actually post to help, unfortunately there are also the same old narcissistic personalities on every internet forum more interested in placing themselves in positions of power over others. When you feel someone is pushing you down, you have 2 options push back or bow down, in this case Software Engineer was over defensive and taking posters requests for clarification as an attack, he does need to chill out, but should also keep his guard up, blender-artists is no special corner of the internet where only good hearted people post.

Im really new to blender but have a lot of experience with other softwares, I had a similar experience just a few minutes ago, and found this while looking up a solution.

Im following a tutorial so Im moving stuff and idk how the zoom in/out distance was exagerated from what it was before and the pan distance too, rotating was alright, so I created a new file to check if there was something that I moved like pivot point, so yeah there were a couple of things so I made them the same and the problem persisted so what I did was copy everything from the “damaged” model into the new one and worked perfectly, I guess it was some bug or something like that cause I didnt mess with any preferences.

I know this is an older topic, but I had the same problem as the OP while getting my feet wet in Blender (former C4D user here). I was able to fix the problem, so if anyone runs into the same problem and also finds his way here, perhaps this can help them as well.

I must have done something wrong, cause by scrolling with the mouse wheel I could only zoom/dolly in big steps. However, using the zoom button in the viewport worked fine. Then I started a new Blender file and noticed a different zooming problem then I had with the one I was working with before. I could zoom up to a point (and going slower towards the end as expected) but at some point it just wouldn’t go further, no matter how much I scrolled the wheel. And the on screen zoom button was acting weird while trying to zoom in or out.

Possible solution: under ‘file’ > ‘Defaults’ choose “Load Factory Settings”
Did it solve your zooming/dollying problem? Then make sure to change some of the default settings, like you have done before and store these settings as a new Startup File. But first make sure to check the zooming/viewing after applying your new settings. Does it still work? Then save the new settings. And it also might be a good idea to make screenshots of your former ‘Preferences’ (under de edit menu) before restoring the factory settings.

It did the trick for me. I probably broke the settings during wrong keyboard presses at some point. Or it was just a bug. But hopefully it will be helpful for someone.

First of all, these are totally different problems than ones from the OP.

Secondly, loading factory settings to reset view center of interest is just wrong, and an extremely bad advice.

“Big steps” were due to you zooming with mousewheel on a tiny object.
“Zoom only up to a point” was due to view center of interest migrating far away from actual center of view as you pan around.
Both of these are solved by re-framing the view to selection via View -> Frame Selected. No preference nuking required. For the other kinds of problems with zooming, solutions are already presented in this thread.

1 Like

Maybe I wasn’t clear or there were more then one problem going on at the same time, but it wasn’t about resetting the view to center of interest. There was no problem in that regard to my understanding. Only the zooming in steps that was going way too fast. Like the camera moved in steps of a few meters. Now it behaves as it should again. After I did the factory (re)setting, the zooming went back to normal. Even on tiny objects in the scene. I also wasn’t able to re-create the problems I had before. It was truly weird. If it happens again I will create a quick video to better show what was going on. But first will try your View > Frame Selected suggestion. Perhaps it’s also good to mention I have rotation around selected object and zoom to mouse point which I always like to work with and haven’t caused problems before.

I have been playing with the zoom and cursor settings recently and have found an improvement to my workflow

I have always liked to Orbit Around Selection (Blender Preferences / Navigation) but recently selected two other options - Auto Depth and Zoom to Mouse Position.

Auto Depth does its best to determine where your mouse cursor is in your 3D space and allows you to zoom in without to many problems with the view clipping out of sight.

Zoom to Mouse Position does mostly what it says and allows you to zoom in to where you mouse cursor is. But this works well with Auto Depth which will also move you through X,Y,X space to where Blender thinks your cursor is in your scene.

1 Like

I’m new to blender and i had the same problem. What worked for me is having the mouse over the object’s face i want to concentrate on. if i scrolled with my mouse was off the object’s face (lets say my mouse is on a another face that is a few meters behind) the zoom would “Jump” too far. But if my mouse was on the object’s face i wanted to work on the sensitivity seemed to decrease. I hope this helps others aswell.