Zooming bug / lockup

Hi – I reported this bug: https://developer.blender.org/T61403
…relating to mouse zooming locking up. Could folks kindly download that test project and try to duplicate?

The reason I’m posting here is that they have marked it “Invalid” but I’m confused at how it could be. Please watch the demo video gif and read the bug closely – it’s not the normal issue that some beginners run in to (here).

I know the devs are busy; I’m just worried that it’s kind of a middle/serious bug that is getting forgotten because of its status.

Thanks!

ugh, just like in 2.79, is some limitation you sometimes have when zooming in perspective view.

Different solutions:

  • use Zoom to Border (Shift B) to bypass the locking up (draw a small border)
  • zoom in with orthographic view

I guess not the solutions you’re looking for, but all there is for now.

Thank you Sago! – Shift-B is a good workaround. But the fact that it locks up the viewport seems like a bug, not a limitation, no? (As mentioned, I’m not talking about the limitation to the zoom, which I understand even though it’s annoying, I’m talking about the fact that a user can no longer zoom in or out once it locks up, or pan, etc.)

Actually I just noticed something: the current version of 2.80 beta (c7cf8282a6ab) doesn’t actually exhibit the bug when there is an object present and you MMB zoom to that object; it only happens when there is no object (or if you MMB zoom in empty space.) So that’s an improvement! (Recent versions, e.g. 779860d34e26, still have the bug even when zooming on objects, but not the latest.)

So maybe someone tweaked things but didn’t bother updating the bug info.

With the same reason you can’t use Shift+B on an empty space in Perspective view, it will say “Depth too large”. But now I discover another bug, which is Shift+B only works on polygon objects and completely ignores camera, lights, curves, etc

I understand why I can’t zoom in when I MMB zoom in empty space. If I zoom in until it stops and I can’t go any further, I can zoom out again. But if I zoom in, and then “push” in farther (even though it does not actually zoom in any farther) then it becomes “frozen” and I can not zoom out, or pan. This is the weird part to me.

I think it has something to do with how blender calculates the point in space that is used for zooming and rotating.

I just use ctrl + shift + MMB to “dolly zoom” out when this happens. Pressing the home key on the keyboard will also recenter everything and fix the issue.

It happens, because blender uses a global point in space around which your view rotates and zooms towards. Other softwares solve this issue, by setting that point to the last position your cursor was at when you press the equivalent of blender’s middle mouse button. The way I solve it (and would recommend to anyone) is by binding a one-button hotkey (like V) to the View to Cursor option. That way I can click, press V, and my view centers exactly where I want it to. IMO that’s the fastest and easiest way to navigate.

Thanks everyone. The dolly zoom doesn’t work for me in this case (it makes only microscopic adjustments.) But I am letting the issue go; I updated the bug report to say that it turns out it’s not actually frozen, just making microscopic adjustments to the viewport. It only takes 2 or 3 screen heights of zooming past the max to “lock up”, but then it takes 10 or 20 to see a very tiny movement when you then try to zoom out. Subsequent zoom-out works as expected. So I have plenty of workarounds now. Thanks for the attention to it.