Zooming In (Noob Question)

Hi guys,

I have about one year experience with Blender and have found something a little odd in almost all modeling programs.

In Blender, I made a few cameras to get better views of my model… but ever since I did that I can’t zoom in with my mouse wheel to get a close look of the model(s) inside my scene.

As I zoom in it slowly slows down the speed of how fast I’m zooming in until it almost stops…

Also I’ve noticed the view is a little weird too and I’m 99% sure it has to do with the same thing.

Can I get some help?



p.s. This all started when I made some cameras.

I do not know how to help you directly, however a workaround is “in any viewport, keep the mouse wheel pressed and move the mouse”.
This will automatically convert the viewport into “User” mode, which should be more useful to work with (e.g. edit vertices) than multiple cameras.
Sorry if you knew that already, hope it helps.

Yeah, I’ve run into this before, wonder if it’s a bug. On my Blender rev. 36332, if I open the default scene, switch the view-port to top view, create a camera a little away from the grid and then switch to perspective view, I can no longer zoom into the cube. It only gets about two-thirds of the way before it doesn’t zoom anymore.

Thats exactly what is happening to me.

I think I’m going to export my model and make a entire new scene and import it and see if that fixes it.

I truly don’t know what to do…

Just did that and it worked.

But I think this should be fixed in the future.

Can anyone confirm this issue, perhaps with a newer revision?

A sure fire way to replicate this in my Blender is:

  1. Load the default scene or factory default.
  2. Zoom with mouse-wheel until you are inside the cube.
  3. Switch to camera view.
  4. Click and hold down middle mouse button and move mouse slightly to rotate (it will switch back to user perspective).
  5. Try to to zoom into the cube again (mine hardly zooms at all).

I’ve always been able to get out of this with the numpad . (decimal) key. Does it work for you?

Yes it actually does, thanks :slight_smile:

Perhaps you can use shift+C too, it is supposed to replace the 3D cursor at the center of the world and show you your entire scene.

I had this problem in the beginning, but it turned out to be simple to avoid:

You can’t zoom past the view center, as you zoom on it, it slows down to a stop, while your objects might still be too far for your taste. Place the cursor near the area you want to work on (check at least two views, the cursor can be very far off on one axis and look no different than if it was right on) and press C to center view on cursor. I find that it works best if the view is centered right in the middle of the vertices I’m interested in.

Thanks guys, but it’s not that you can’t zoom past the center (understandable), but that the point where the zoom slows/stops changes dramatically. You can try the steps I’ve outlined in post #6 to see what I mean. It’s as if the relationship between the world units and the view-port gets out of sync.

I just downloaded a more recent build (37117) from GraphicAll and the issue is still there. I’ll check the bug-tracker in the meantime and see if it’s listed. It’s probably not critical as the Numpad Del (.) key works around it, but it’s going to catch a few new users out.

Hmm… looks like it’s related to the orbit point and not necessarily a bug. Found this closed entry in the bug-tracker from a month ago:


Not entirely the same thing, but there’s a new dolly feature in 2.57b and there’s also a link to a short Youtube demo on the “Auto Depth” option if people running into the same problems are interested.

Although I think I’ll just stick with “view selected (Numpad DEL)” for now, works fine for me.