Zooming/Panning in 3d View becomes slow

Hi guys, new to blender.

I love being able to zoom and pan in the 3d View so intuitively. Although sometimes I noticed zooming slows down to a crawl and I’m not sure why. Some googling suggests this has something to do with the 3d cursor position. Is there a way to make zoom/pan speed stay consistent?

Thank You!

I have sometimes experienced this. I switched “Smooth Scrolling” off in my Logitech mouse settings, and it stopped.