Zooming problems since 2.63

Since the release of 2.63 I have major problems with the interface in Blender. I use Blender on a Mac with a Magic Mouse and never (either in 2.4 or 2.5) had problems to use it with 3-button-mouse emulation turned on. Zooming in on an object worked fine, so did rotation and panning.

But since 2.63, I can’t zoom anymore. The “mousewheel” only shifts the view up and down and sometimes erratically zooms in or out - uncontrollably.

Changing the Zoom Style doesn’t do anything, the behavior is always the same. I tried 2.64 preview, but the problems are still there.

Did anyone experience the same problems and / or has a solution / suggestions?

Assuming that you have a backup copy of your user preferences, did you try Load Factory Settings as a last resort?

Append everything in ur problem .blend to a new file. Problem solved!

I tried to reload the factory settings, but it didn’t change the behavior. I checked all the input settings for 3D View and “Wheel in” Wheel out" (or “Wheel up” “Wheel down”) is only set for “Zoom view” - but it still only pans up and down and sometimes zooms in / out to the maximum level.

I also deactivated all of the “smart” mouse behavior in SystemPreferences - no change.

I guess I will have to get used to zoom with alt-ctrl instead of the wheel.