Zooming with the mouse wheel is not working

Suddenly, in the 3d viewport, zooming with the mouse wheel is not working.

2.82

Ideas?

Is your timeline scrolling instead? If so, it might be that your alt key got “stuck”. Happens to me on Ubuntu sometimes. Resizing the window makes it go away.

Could be that your mousewheel gave up, happend to me twice. Did you check it in other applications?

Still works as expected in Blender 2.79

PS - and 2.80 is OK

I don’t think so. It has to be something on the software side. If I resize the window Blender is running in mouse wheel behavior goes back to normal.

From above:

Have you tried resetting your keymap? Perhaps something got changed accidentially.

“resetting your keymap”? Is there an easy way to do that - or should I check each setting?

You can either reset to factory settings in the hamburger menu in the lower left corner of the preferences (but this resets ALL preferences which you probably dont want) or you could set your keymap in the drop down menu in the top left from “Blender” to “Industry Compatible” and check if it works.
If it does then you know that something with the “Blender” keymap is wrong.

Nope. Tried - but do difference.
What happens is…
I start Blender from scratch
I zoom in-an-out with the mouse wheel for a few seconds
But each zoom is less than the previous one, so eventually it just stops zooming.
Mouse wheel zooming is OK in Blender 2.79 & 2.80

Does this happen in perspective view only or also in ortho?

OK, this was weird…

On a hunch, I switched to a different view angle with the number pad keys.

Suddenly I was zooming OK in Left, Front and Top views, then I dollied the view, and zooming continues to work.

???

Will revive this thread if if figure out how the problem started.

So, everything is OK. Thanks for your thoughts.

Ya know?? You may be onto something with that.

Now that it’s OK I can’t seem to get it to fail. So, I’ll update if I discover something other than user error. LOL