ztransp and vector blur issue

I wanted to use vector blur and a ztransp backround image (means a ztransp plane behind the other objects). However where the background is behind my solid objects the solid objects won’t get blurred. This is in 2.43. In 2.44 it seems to work, but the renderfarm I’m testing doesn’t support 2.44. Was it a bug in 2.43? Is there more documentation anywhere?

I somewhere read that objects behind ztransp faces can not be affected. But in my case the ztransp faces are behind the solid ones

What different approach could I take to get a full vectorblur? (Renderlayers, z-combine? Can you z-combine ztransparent objects in general, cause my first attempts failed? Last solution raytransp?

Use motion blur instead with 2.43, or ask your farm to upgrade. We are offering a FREE UPGRADE to BlenderArtist members to 2.44. This is a limited time offer though (until 2.45 comes out). And the upgrade takes, oh, i dunno, two minutes to perform.

Just seperate your objects onto seperate render layers and it will work just fine. That is strange though. It must be causing some type of conflict in the depth channel.

Like this:


Thank you very much for the supplied file.
It turns out that I need ztransp in the scene more often at different places.
I think I can’t compose that, can I?

Yes, you can. There’s not really a limit to what you can do with the render layers. Just be sure to enable the Ztra button on the render layers tab for all ztransp. render layers.

1 Like