Results 1 to 2 of 2
  1. #1

    Armature Doesnt Move Mesh

    (Obvious Noob Alert) hi. im trying to port some tron 2.0 models (old 2003 game) and it keeps on fighting me. i barely managed to get the materials to work, when it threw a curveball and decided that the armature wasnt going to move the mesh. since i dont have any skills in rigging or anything like that, i have always used its always worked for me with results that usually range from nearly perfect to yeah thats good enough but this time it just stopped working. im trying to figure out why it would rig, but not move the mesh at all. ive tried other things like setting the objects parenting, but they make the mesh turn 90 degrees and deform it. heres the blend file:
    Attached Files Attached Files

  2. #2
    Member clockmender's Avatar
    Join Date
    Nov 2014
    East Leicestershire, UK
    Your armature is both rotated and scaled in Object Mode - ain't ever going to work...

    Click image for larger version. 

Name:	Screen Shot 2018-04-16 at 12.20.36.png 
Views:	2 
Size:	167.5 KB 
ID:	521353

    See your rotations are 90,0,0 and scales are 0.467,0.467,0.467 for the armature, not good.

    You need to "Apply" the rotation and scale - key CTRL+A => "Rotation and Scale" and next time do all edits in EDIT mode, like rotating, or scaling the armature. Armature and Mesh object should have 0,0,0 as Rotations and 1,1,1 as scales, then you can parent the mesh to the object and it will be fine - I would chose "Automatic Weights" as the parent type first and then tweak the weight with weight painting if necessary.

    Cheers ,Clock.
    K.I.S.S - a good maxim I think, and Granddads know best!
    "You are completely bonkers." - @Gumboots
    Youtube Channel Website Still rebuilding this, but it is started at last

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts