Armature Doesnt Move Mesh


(SpiritedSpy) #1

(Obvious Noob Alert) hi. im trying to port some tron 2.0 models (old 2003 game) and it keeps on fighting me. i barely managed to get the materials to work, when it threw a curveball and decided that the armature wasnt going to move the mesh. since i dont have any skills in rigging or anything like that, i have always used mixamo.com its always worked for me with results that usually range from nearly perfect to yeah thats good enough but this time it just stopped working. im trying to figure out why it would rig, but not move the mesh at all. ive tried other things like setting the objects parenting, but they make the mesh turn 90 degrees and deform it. heres the blend file: http://pasteall.org/blend/index.php?id=49325

Attachments

untitled.blend (382 KB)


(Clockmender) #2

Your armature is both rotated and scaled in Object Mode - ain’t ever going to work…


See your rotations are 90,0,0 and scales are 0.467,0.467,0.467 for the armature, not good. :no:

You need to “Apply” the rotation and scale - key CTRL+A => “Rotation and Scale” and next time do all edits in EDIT mode, like rotating, or scaling the armature. Armature and Mesh object should have 0,0,0 as Rotations and 1,1,1 as scales, then you can parent the mesh to the object and it will be fine - I would chose “Automatic Weights” as the parent type first and then tweak the weight with weight painting if necessary.

Cheers ,Clock.