2.34 Ramp shader and UV assigned colour textures.

I’m not sure if this is a bug, or if it’s just not possible.

Add>Cube Add>New Material.

Enter face mode for cube and uv map an image.

Assign the same image as a texture in the material for the cube.

Leave Col for the texture turned on, use UV for mapping co-ords.

Make shader a ramp shader, change colour ramp if need be.

When rendered the colour from the UV mapped image is not showing through as it does with a normal shader.

Is this a bug? It would be sweet to use UV maps and ramps, but I could manage otherwise.

Thanks for any help,


If Method = Mix then drop the Factor value (or use alpha in the colorband).

I just tested it with UV and I can’t say I see much difference with and without, Mix and Screen methods being the most obscure in both.


Thanks fligh% I knew it would be something simple.

It seems to be quite hard to find information on how to use the newest features.


From information given to me by @ndy during a conversation on #BlenderChat, use the RESULT option instead of MIX. Seems to get the best results. But that is based on skin materials. May be different with paint and image files.


Thanks, BgDm. It’s so the ramp car paint shaders can be made with graphics for the sides of the car. Will experiment more.

Thanks again.