2.40 smooth problem

I have a mesh which consists of a lot of cylindes (it’is a model of a valve). Looks like 2.40 draws smooth surfaces differently compare to 2.37a. As an example I’d created very simple mesh - just a single cylinder, and set “smooth” for external faces. This is how it looks in 2.37a nad 2.40:
When rendered it looks fine, but while modeling it is quite annoying.

Try a different shading method (ALT+ZKEY)?

It is “solid” method. If I select “shaded” it looks even worse.

your just finding alot of these arnt you :smiley:

I may be a little out there, but 2.4 seems to calculate some lighting in the OpenGL windows (3D windows) while 2.37 doesn’t. This may all be because of that.

Yeah, I think this might be a problem:

Cylinder without Smoothing (no material, internal renderer)


Cylinder with Smoothing applied (no material, internal renderer)


These images rendered fine with Yafray.

Yep, that’s right :smiley: I just installed 2.40 and loaded one of mine models - and immediatly found that “solid” shading is different, face/vertex loop does not work anymore in interactive mode… I’m afraid to open any of my other models - who knows what else was “improved” in this release . :o

You said in your first post that they rendered fine. But just now you say that they render fine in yafray, but look like this in the internal renderer?

It’s an odd problem you got there, my renders look just fine with 2.4
Try making an actual material for them before rendering btw (not changing anything, just make one), might help.

avc said it rendered fine.

I said it looked awful with the internal renderer. It shouldn’t look that way, no matter if it had materials applied or not.

“Recalculate normals outside box” don’t fix it?

It doesn’t work.

Give it a try. Make a cylinder, smooth it and render it.

If you turn on auto-smooth it works fine. Without autosmooth it is trying to make the sharp edge appear round – hence the strange artifacts.


I agree – I liked the old appearance in the 3d window better.


Thanks GreyBeard.

Sorry, guess I shouldn’t be too cocky during those hours.

In mine case blender renders it fine - the only problem - 3D view window, it looks awful. Maybe 3D view depends on OpenGL settings somehow, I don’t now, but 2.37a version is much better.

The problem itself may be quite simple (and I agree I’ve noticed the difference in 2.40 and don’t like it – even with all normals outside). Anyway here’s what I see…

In 2.37a with “Set Smooth” turned ON but with “AutoSmooth” OFF you get virtually the same look as you do with 2.40 and AutoSmooth is ON. Which is the look I believe is being discussed here. It would seem that setting “AutoSmooth” on in 2.4 does not change the way the shaded view is generated. It’s late so I hope all that made sense.

Oh yes, things are rendering fine so far just the look of things in the 3D view as mentioned above.

Yes, render works fine, but I just cannot work with dark shared surfaces in 3D view. In 2.37a if you see such a dark stripes you knew that your selection of faces to smooth was wrong and then you could you fix it. Now, in 2.40, it does not matter how you do your selection - you still get these nasty dark stripes and you can fix it only after you render an image to make sure that it is really wrong.

duhast: The internal render problem seems to go away if autosmooth is set. 2.37 treated it differently by softening the flat end making it look slightly domed when viewd from an angle but it still appeared flat from side-on which is clearly not good if you want accuracy. I guess the new method at least shows the problem more clearly :slight_smile:

I’m not experiencing the viewport problem (Mac 10.3.9 py2.3) but looking at the images, I wonder if you might have different OpenGL light settings? Check in your user settings and maybe try different values for the three lights (System & OpenGL settings). Maybe compare your current values to those in 2.37 too (although I think if both are on the same system they use the same default setup).

I’ve tried everything - autosmooth with different values (did not help at all), different OGL light settings (I could make it worse, but not better). Plus 2.40 locks up on my PC almost every 10 minutes - does not matter what I do - just clicking on menu buttons or moving mesh or lights. So I back to 2.37a. Looks like it’s only me who’s having such a collection of problems with 2.40 :frowning: This is an exemple how the same blend file looks in 2.37a and 2.40:

I made some comparisons myself. Here is the default startup blend that has a cube, a lamp, and a camera. Now I’m not claiming this as a bug, however, if it’s not a bug it’s a specific design change. And not one that I really care for.