2.47 bug? (rabbit.blend problem)

if I open rabbit.blend of BIG BUCK BUNNY with 2.46 all is ok…

but if i open with 2.47 and i try to move the armature… look
what’are this deformation???
maybe all the constraint script are off in the 2.47…
hey, help me!!

I just took a look at it but cant look further simply because i go to bed now ^^
The Actions for
CTRL_Belly and CTRL_ChestF
are off normal somehow. If you turn their influence to zero all is back to normal. ^^
Deformation will still work but not the actions.
If someone finds out whats wrong during my night its fine… else i take a look into it tomorrow.

You need to ensure that the “enable scriptlinks” option is enabled if you are working in 2.47 +. This is because the pyconstraints (and also pydrivers) in the rig are now only executed when the “enable scriptlinks” is on (due to security reasons)

In SVN-Trunk, there were some changes made to fix a bug related to this, when rendering a single frame from the UI, the scriptlinks flag would get disabled, thus screwing up armatures again.


If you are suing builds from SVN “enable scriptlinks” is usually already switched on.

Aligorith: Recently I have notices that offset feature for constraints were changed (SVN). Now it works really nice and provide more freedom for rigging so big thank for this. (sorry I do not want to hijack this thread but this was an occasion how to say thank to Aligorith.

edit: JiriH and Aligorith beat me

ah!ok solved

Added note to 2.47 release page about this change.

AFAIK scriptlinks are also enabled in the “default” 2.47
at least it is in mine, but somehow on load with UI of the rabbit.blend it seems it disables the scriptlinks.