2.47a: UV Mapping issue

I’ve been trying to UV map some icicle formations I made on a model; however, Blender has an odd habit of turning some faces on almost every model into separated quads and overlap two of their corners to form triangles. Sometimes, like here, it’ll group these little deviants with the UV group they’re from, but on some other models I’ve mapped, these islands will be scattered all over the image and I have to hunt them down and find out which vertices go where.

What’s causing this and how do I circumvent it? It’s getting a little irritating as it eats up a lot of my time when working on these projects.

What are you using as an unwrap command? I find that once I have set a seam, it is better to use ‘unwrap’ than to use smart unwrap.

You have inconsistent normals.

Best wishes,

I use the “U” keyboard shortcut and “Unwrap” from that menu.
Forgot to specify, this is Blender 2.47a.
I add all my seams, then once everything’s seamed up I highlight everything, hit U, Unwrap, then analyze the map and add/delete/adjust seams that give problems.

Inconsistent normals? How do I solve that? :s

Go into edit mode, select all, press ctrl+n to recalculate normals. Also, if you want, when in Edit mode, in your 3D window’s properties, there is a “mesh display” option. You can check the “Face” option and then increase the “Normal Size” until you see blue lines poking out of the faces. You want all these blue lines pointing OUT. (Recalculate normals should do this automatically, but sometimes, especially for complex models, it needs some tweaking, where you select individual faces & flipping normals.)

huh… I did that last night and it gave me that funky error, but now it works o.o
I don’t get this… xD;
the Join Meshes command sometimes won’t join meshes, and now the Recalculate Normals won’t always recalculate them…blarg.

Thanks for the help though