2.48a Jorgie Performance Build

Attention: This build, by Jorgie, addresses the performance loss that some may have experienced inside the game engine since 2.48 and 2.48a were released. Check the latest posts for future updates.

>>> 2.48a Download Link: http://www.savefile.com/files/1854990 <<<

Hi there - just did a test. had to make a lot of polygons to slow it down below the maximum speed. The release appeared to be a tiny fraction slower 27.8 / 28.6 in my test but that could be anything. content of the blend could affect speed to (ie python). Have you got ‘enable all frames’ checked in one of the builds? just a thought.

XP pro 32bit, E8400, 3GHz, 4GB, 8600GT

It could be that Blender 2.48 was compiled with largeawareadress which make the GE slower i´ve heard I think, but lets you use more ram.

Do you have SSE2(think it´s called this) support if so I could give you my optimized build with fast float calculations rather then precise, I use fast because it seems to add some speedup for bge, this one is built without largeawareadress so you could give it a try and tell us if you got some speedup changes.

If you decide to give it a go then you will have to wait until I get home currently school.

Wow, for me it’s sped up, I’m running a massive scene with softbodies at 60fps

please note that 2.48 final has a memory leak in 64 bit systems caused by bullet, its fixed now, and will be in 2.48a

thanks guys, but it’s the Rasterizer that’s the problem I think - It shows 2x the %.

For example: in RC1, where a scene says Rasterizer: 20%, in 2.48 it reads 40%. Why would that be?

In my test blend RC1 = 94.5% and release is 94%

I’m not getting huge slowdown here despite rasterizer percentage going up.

Check to see if another percentage on something else went down, usually if a percentage of one thing goes down another goes up as you can’t have anything with the percentages add to something less then a hundred

If you decide to give it a go then you will have to wait until I get home currently school.

Can you build from the latest SVN? Benoit fixed a few things since 2.48

Yes i can, do you all want a optimized build or a unoptimized build?


Blender Unoptimized Revision 17141
builded with every project except the web plugin because it doesn´t work with windows yet,
builded without largeawareadress
builded with OpenMP

Blender Optimized Revision 17141
builded with every project except the web plugin,
builded without largeawareadress
builded with OpenMP, SSE2(every project) and Fast float calculations(every project except BF_ELBEEM(Fluids) and src)

hope those who can and have SSE2 support will test both and see if they see any performance difference.
I myself get 1.5-2 frames improvement from the bathroom demo.

Thanks in advance

There is no way i can justify moving from 247.9 to 248 with numbers like these. And people act like they don’t beleive me but there is something fishy going on with the 2.48 build.

What could have changed so much to cause this?

(bathroom demo)


Well here’s me
These tests were done with ‘enable all frames’ checked. Other wise I get limited to 60Hz, (interestingly the physics goes up by 3% in that case). I have noticed recently that the frame rate never goes above 75Hz on my computer (movement is very smooth), no matter what the blend is, and most of the time its stuck on 75Hz…so I was intriged to see your high figures. We’ve both got Nvidia 8 series cards - wonder what your graphic card setting are?

Basically there is a huge difference between 8800 GT 512 and anything less. So having an 8 series simply means you have a card of the same generation. So I’m not sure what your 8 Series card is exactly.

8600GT with 512MB - not as fast as yours but not slow. As I say the weird thing is it tops at 75Hz no matter how simple the blend. and you need quite a complicated blend to make it go below 75Hz. If I delete the default cube and press p it says 75Hz. like its locked to screen refresh rate. (enable all frames is on). I wondered why yours was so different thats all… could be a clue

larryboy i think yours frame stays on 75 because you have Vertical sync on try turning it off on nvidia control panel then try again
I had the same problem with my graphics card geforce 7900 gs

Thank you Jorgie, That was the case … and now I want a 8800GT as its a lot faster… BUT now I have to agree with kay_Eva, the release build is a lot slower

After some hours of compiling Blender(6 builds to be exact) I´ve finally found which SVN commit caused this performance downgrade it was svn commit 17019
here´s the link to the commit


We need to know why this commit was worth the severe framedrop.

I am aware of this performance drop, that commit reversed another optimization made earlier in the 2.48 development because it was giving graphics card glitches. Note however that the game player still has the optimization, which is what presumably would be used to distribute the final game.

It wasn’t causing any glitches for me, can it be a quick option to toggle?

Anyway, many play Blender games in the 3D view, we must have the ability to have this optimization while playing games in Blender itself.

Here is the svn 17151 version with the old perfomance back

to modify the perfomance back just remove the line glFinish(); in trunk/blender/source/blender/src/ghostwinlay.c
somewhere around line 478 when compiling Blender

The wierd thing is my game runs about 5-7 frames slower on a first run without ‘enable all frames’ than with 2.48, I have the FPS capped at 60 but that is wierd.