2.48a - trouble adding second Lamp

Hello Blender people,

This should be really simple: add a lamp using Space - Add - Lamp - Lamp. But when I try to do so, the new lamp is nowhere to be found. It has a reference in the Outliner but it’s absolutely nowhere to be found. I tried zooming right out in all views

I tried another trick, duplicating the existing lamp, then translating it in the 3D view. But when I try to move the play-head in the IPO editor, the new lamp magically vanishes (actually I think it snaps back to the same place as the original lamp. I tried adding new keyframes to the duplicate, but there seems to be some connection between the original lamp and the new one, and I can’t separate them out. This makes one of the lamps move, and the other vanishes.

Either way I can’t work out what’s wrong. My animation is already complex (it should be finished today …) and I can’t start again. It consists of a number of objects that move in time. Adding lamps in a test scene - which has no animation - works great. But I can’t seem to add a lamp to this scene. Can someone help me? I hope I’ve given you enough to go on.

Please help !

Objects are added at the location of the 3d curser which is probably too far away in your view (see the view clip distances in the view and camera properties). Shift+C (I think) brings the curser back to 0,0,0. Then add the lamp. You could highlight the lamp in the outliner and type 0,0,0 as a location in its transform properties (N).


Hello Richard,

thanks for your amazingly quick reply. The transform box did the trick! For some reason the new lamp was created at coordinates marked “nan” (presumably Not A Number).