2.5 Beta not loading 2.49 files?

After the Beta release I decided to finally commit to using 2.5. Trouble is any 2.49 file I try to load that is more than just a mesh (ie. contains ipos and shapes and textures etc) the program crashes. Is it only me? (using 32 bit version on windows xp)

You’ve probably tried this already, but just see if it is only an issue with the file your trying to open. I’m also running windows 32bit on XP and it opens 2.49b files just fine.

Can you try a more recent build from trunk? Some bugs were fixed shortly after beta that might have caused this crash.

Hello, maybe related or not i have no idea but 2.53 sculpt mode seems to have a problem with some 2.49b meshes.

Some time ago, i sculpted some cartoonish head on Sculptris and imported it in Blender 2.49b in which there was no problem, i could sculpt it from 2.49b sculpt mode etc… (Sculptris not allowing the resculpting of an UV mapped mesh without losing the whole UV).

I saved it as a .blend, could then re-use this .blend in 2.49b no problem too.
The .blend has an uvmap, a strange one as it was saved from the automatically created texture map in Sculptris, but 2.49b has no problem with it.

I wanted to try the new sculpt features of 2.53 and so loaded the 2.49b blend.
And there, it behave extremely strangely, the draw brush result in this :

If , always in 2.53, i export this .blend mesh as a OBJ, then import the OBJ again, this time 2.53 sculpt mode works as expected :
so i guess there is a 2.49b information in the .blend that puzzle 2.53 and that disappear during the OBJ export/import that make the mesh workable again.
And strangely when i see that bug, all the brushes disappear (from the panel with every brush icon, not from the Tool submenu) only the Draw brush icon is left, to get every brush back i need to “load default factory setting”

my system is on window XP SP3, using a Intel G31/33 GMA 3100
If it can help to find the source of this bug , here is the .blend (orgo0.blend inside of the orgo0.7z archive) :

Sculpting with a mesh created from scratch in 2.53 have strictly no problem with the sculpt mode, it is this kind of 2.49b meshes.

I tried with a recent Zebulon build from Graphicall, and same exact problem, opening directly the 2.49b .blend into 2.53 makes it unworkable unless i first export to OBJ then reimport it back into 2.53

That’s kind of strange, even if you append the mesh to a new scene (which takes care of the disappearing brush problem BTW) it still does the spikes when using the draw brush.

The reason you get those spikes is because your object is scaled down. At the moment sculpt mode only works fine with objects that have a scale of 1.0.
If you have a normal mesh applying or clearing scale will fix your problem.
If you are using the multires modifier scaling will mess up the displacement so be carefull.

Thank you.
I pressed ALT and S to remove whatever scaling the object had.

And i was surprised to see that the mesh was gigantic (in perspective view) in comparison to the Blender 2.53 grid (i don’t remember having scaled it down in 2.49b).
But at least sculpt mode worked on it.
scaling it down to more reasonnable size in comparison to Blender 2.53 grid re-activated the bug.

After trying now i understand 2.53 sculpt mode has trouble with objects considered or automatically scaled down, making Object->Apply->Scale ( or CTRL + A -> Scale ) to make the current scale being the new 100% scaled one apparently fix the problem too fortunately.

Though the brush disappearance is not fixed by this, even saving and load the “scale applied” mesh will make every brush minus the draw brush disappear.
You need to Append this model as Uncle Entity hinted, then save it into a new .blend, this way the brush will not disappear anymore when you will load the new .blend and you will not have anymore the spikes as the object is scale applied.

Thanks to everyone with their suggestions. I just went to graphicall.org for the most recent build and my antivirus program blocked access because of “twitterall.js”. Does anyone know about this?