2.62 UV tools cause problems

Hey there,
I’ve got another rant here about blender 2.62+ .
I’ve written a script which converts particle hair into uv unwrapped mesh hair and I just tried it on the newest trunk version of blender. However, the simple “UV unwrap” tool doesn’t work properly anymore. Once it handles a large amount of islands, it scales them randomly.
Like, on the left is how it looked in 2.60 , and on the right is how it looks now.

Somehow unwrap UV still moves vertices even if they are pinned. I’m sure of this because I tried it by hand.

I hope someone who knows more about this new UV system could enlighten me here.
Could we maybe get to choose between a “legend” version of uv-unwrap, and the new one?

,Happy 2.62 + :stuck_out_tongue:

This belongs in the bug tracker with blendfile attached:

you think it’s a bug? I purposefully posted it here to discuss just that. To me it looked like a function which prevented vertices from being right on top of each other in terms of uv space. So I thought maybe someone here knew if it was intended or not.

EDIT: but if it’s you who says it needs to go in the bug tracker, then it’ll go there ;D